Warning: mysqli_real_connect(): Headers and client library minor version mismatch. Headers:50625 Library:50543 in /sites/rockbox.org/flyspray/adodb/drivers/adodb-mysqli.inc.php on line 108 FS#8525 : Cannot play last file in directory



FS#8525 - Cannot play last file in directory

Attached to Project: Rockbox
Opened by Mark (Revenger) - Monday, 28 January 2008, 07:25 GMT
Last edited by Nicolas Pennequin (nicolas_p) - Monday, 25 February 2008, 22:41 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To Nicolas Pennequin (nicolas_p)
Operating System iPod 5G
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


Rockbox refuses to play last file in the directory taking the user right back to the previous menu screen.
This task depends upon

Closed by  Nicolas Pennequin (nicolas_p)
Monday, 25 February 2008, 22:41 GMT
Reason for closing:  Fixed
Additional comments about closing:  Should be fixed by r16392.
Comment by Dave (dberg918) - Monday, 28 January 2008, 16:04 GMT
This also randomly happens to me when there's only one file in the directory. Randomly in the sense that it will play certain one-file directories, but not most others.
Comment by Peter D'Hoye (petur) - Monday, 28 January 2008, 20:51 GMT
Not seen here and unable to reproduce

Any more info or settings that matter?
Comment by Mark (Revenger) - Tuesday, 29 January 2008, 00:55 GMT
I think its related to rockbox track numbers beeing 1 higher in some circumstances as it seems to happem when rockbox thinks track 1 is track 2 and you play 2nd last file rockbox thinks its the last track.

Video of it refusing to plat at www.guildwars.tyria.net/files/dump/rf.wmv

As for settings that vid was taken on a complete clean install of the latest build no settings applied apart from theme and eq.
Comment by Dave (dberg918) - Tuesday, 29 January 2008, 16:01 GMT
I have a couple of patches in the build for my Gigabeat F40:

lists using viewports (task #8457)
viewports in WPS (task #8385)

I'm using a home-made WPS that utilizes viewports and album art.
Comment by Linus Nielsen Feltzing (linusnielsen) - Wednesday, 30 January 2008, 08:27 GMT
Does the problem occur if you run an unpatched version of Rockbox?
Comment by Nicolas Pennequin (nicolas_p) - Sunday, 24 February 2008, 17:38 GMT
Has this gotten better with r16392?