Rockbox

Tasklist

FS#8651 - Screeching, High-Pitched Noise after Crossfade

Attached to Project: Rockbox
Opened by Humberto Santana (hhannah) - Tuesday, 26 February 2008, 20:10 GMT
Last edited by Andree Buschmann (Buschel) - Sunday, 30 March 2008, 10:17 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System iPod 5G
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

THIS IS A DIFFICULT ONE!

First, I must say that I've found this bug VERY difficult to report, because although quite frequent, it is VERY "slippery" (maybe attempted to be described in the past many times (see [*] below) - from what I found in the flyspray & forums) I kind of feel like a ghostbuster here!. I've been "coexisting" with it since I installed Rockbox in November/07. It is related to crossfading, which I use all the time (main reason for coming to Rockbox!). I will do my best to give the relevant information I've found, and also, I kindly request experts' help/ideas on what to check/try in order to find the causes with more accuracy, if that's necessary in addition to the information I present, in order to solve the bug (please notice that this is NOT a support request!).

- iPod video 80GB 5.5G
- rockbox r16422 (but also happened in previous versions, at least from November/07 to this version)
- mp3 format (both in variable and constant bitrates)

*Description*

Eventually, shortly after crossfading (or right during the crossfading process), playback stops advancing and a screeching, high-pitched, almost hurting, repeating noise begins. I've attached a recording of the problem so that you can actually hear it (sorry about the sound quality, I didn't find a better way than a mic).

Other functions seem to keep on working normally during this noise problem (wps info, menu browsing, etc). To stop the noise, I've used the Prev on the clickwheel, and the current song re-starts ok. If I attempt a forward skip, the noise continues. If I pause, and then resume, the noise continues. If I reboot, when going back to "now playing", it resumes OK but in the previous song to the bug, close to the end of that song.

*To Reproduce*

Now THIS is the main difficulty with this bug, I haven't found a way to reproduce it precisely (I've invested a lot of time in this, but all I've got is what's describe here). I just use crossfading continuously, and sooner or later, the bug appears. In order to give more information about this, I took two actions. 1. I checked the view options in the "debug menu", and 2. I've tried different setting combinations, discarding possible causes.

1. In the debug menus, I've noticed the following:

- In the "View buffering thread" option, the pcm bar/values rise almost to the top and stay there during the noise. In normal operation, it goes down after the crossfading process. Also, the CPU freq is 30Mhz during the problem.
Typical values on this screen during the problem are (values vary slightly from bug to bug):

pcm: 3170592/3175200
alloc: 56297688/60322272
real: 54987063/60322272
userfl: 394555113/60322272
data_rem:4567692
track count: 6 (has happened with values 0 to 7, so far)
handle count: 21 (has happened also with i.e values of 18)
cpu freq: 30Mhz (always ends with that value when the bug occurs)
boost ratio: begins with 100% when the problem starts, goes down gradually to 0%. Is the THIS IS THE ONLY VALUE ON THIS SCREEN THAT CHANGES DURING THE PROBLEM, THE OTHERS REMAIL STATIC.
pcmbufdesc: 92/129

- In the CPU Frequency option (debug menu), the values during the bug are: (ALWAYS)
Frequency: 30000000
boost_counter: 0

2. Discarded possible causes

Given that crossfading is enabled (different fade-in and fade-out durations, fade-in delay set to 0, fade-out delay set in tests to a value > 0, fade-out mode set to crossfade), I've tried different combinations for the following settings, but since the bug occurs with or without these settings, I guess they can be discarded as possible causes:

- Equalizer enabled or disabled, different specific values.
- All the other "sound settings" were always in their default values.
- Replaygain enabled or disabled, any mode, clipping enabled or disabled, pre-amp any value.
- Any mp3 bitrates (different kbps and/or variable-constant rates in songs involved during crossfading)
- Shuffle enabled or disabled, any mode.
- Repeat enabled or disabled, any mode.
- All the other "playback settings" were always in their default values.
- Any wps loaded (just in case the theme .cfg could have some effect)

[Also in the attachment a typical .cfg]

3. Additional information

Because I can't be 100% sure that the following information relates to the bug, and because this doesn't happen ALL the times the problem occurs, I just put it here in case it gives someone a clue:

After the problem occurs:
- Sometimes after normal playback is restored, crossfade doesn't work anymore. At the end of the song it sort of begins the crossfading process, but the songs are not mixed finally.
- Sometimes the iPod crushes when operating it after the bug restore, the screen is the theme's wps .bmp, the text displayed "Undefined Instruction at 00069DC4 (0) [code's last 3 digits vary]
- Sometimes browsing and normal menu operation becomes very, very slow


Thanks in advance! And if there is something else that I can do to help, please just let me know.

----------------
[*]
THESE SEEM TO REFLECT THE SAME PROBLEM:
http://forums.rockbox.org/index.php?topic=3860.0
http://forums.rockbox.org/index.php?topic=15406.0
http://forums.rockbox.org/index.php?topic=8946.0
http://forums.rockbox.org/index.php?topic=6281.0

Similar reports (but most probably not the same?):
 FS#7214 
 FS#8597 
 FS#6117 
 FS#7635 
 FS#8498 
 FS#8600 

http://forums.rockbox.org/index.php?topic=8335.0
This task depends upon

Closed by  Andree Buschmann (Buschel)
Sunday, 30 March 2008, 10:17 GMT
Reason for closing:  Fixed
Additional comments about closing:  Committed with #16889 and #16890.
Comment by Ben Zavala (bzavala) - Wednesday, 27 February 2008, 18:53 GMT
yep.. I also have the same problem. I also use Crossfade. It happens randomly. I have a 60 GB iPod video.

In my case, it happens almost 30 mins or so after starting up rockbox (i.e. ipod is turned on).

Today I decided to take crossfade out, and the iPod has been playing all morning with no problems at all.
Comment by Steve Bavin (pondlife) - Wednesday, 27 February 2008, 20:44 GMT
I don't doubt this is a problem on PortalPlayer targets, but it may be useful to know that I use crossfade on H300 all the time and do NOT get this problem.

I'd guess that this may be related to the problem where keyclick is played as a beep/horrible screech noise on PortalPlayer targets. Maybe someone with a suitable target could perhaps enable keyclick and get debugging pcm-pp.c?
Comment by Humberto Santana (hhannah) - Wednesday, 27 February 2008, 21:49 GMT
@bzavala: As you say, I also usually get the problem after 20-30 minutes, but that's on average; it also happens sometimes a few minutes after turning it on, and sometimes after a couple of hours...

@pondlife: For what's worth, I always have Keyclick=Off and Keyclick_Repeats=No
Comment by Steve Bavin (pondlife) - Wednesday, 27 February 2008, 21:56 GMT
I don't think this is caused by keyclick, but I wonder if the intermittent screeches that keyclick can give on PortalPlayer are showing up the same underlying problem. Perhaps you could enable keyclick when you get this problem, then see if every key press gives a similar unpleasant noise? Protect your ears...!
Comment by Ben Zavala (bzavala) - Wednesday, 27 February 2008, 22:11 GMT
hhanna: I played the ipod with no crossfade for about 3 hrs this morning, and right now it was been playing for another 3 hrs with no screeching sound again.
Comment by Humberto Santana (hhannah) - Thursday, 28 February 2008, 13:55 GMT
OK pondlife, I did what you said and here is the report [first, thanks for the advice on protecting my ears :) really important for dealing with this problem]
I did the test in two ways, a) enabling keyclick settings and then waiting for the bug to happen, b) having keyclick settings disabled, and enabling them when the bug happened... but (unfotunately?) in both cases no key or scrollwheel action generated more noise (or less); the noise-silence cicle that repeats wasn't increased, interrupted or modified at all
:(
Comment by Ryan Sawhill (ryran) - Saturday, 01 March 2008, 18:49 GMT
Wow Humberto. Nice job getting recordings. Hah. That's impressive.
My experience: I've been getting this periodically on 2 separate 60GB 5g ipods ever since I first installed Rockbox back in '05. Like..maybe a half-dozen times a year, well.. up until recently--it's hard to quantify, but my subjective perception is that the probability of it happening has definitely increased sometime in the last few months. It's been something that I've never worried about precisely because it's so random and because it seemed like no one else was experiencing it. Not sure what will happen but thanks for making the report hhannah. :)
Comment by Humberto Santana (hhannah) - Monday, 03 March 2008, 21:58 GMT
Ryran, thanks for your comments... :) well... I guess that on these recordings at least someone can get an idea how annoying this bug really is :)
I wish I was as lucky as you, only getting the problem once in a while, but the thing is I use crossfade ALL the time, so I get the noise quite often. The question for you would be how often do you use crossfade, and how long are the listening on crossfade periods. For example, if someone uses only "crossfade when track skipping", and she only skips songs a few times, crossfading occurs only a few times and not one song after the other... that would be something quite different as listening music for 2 hours continously, using crossfade set to always.
Comment by Ryan Sawhill (ryran) - Monday, 03 March 2008, 22:51 GMT
Yeah. I realized that before I posted--I have crossfade set to shuffle & track skip and I usually only use shuffle when I'm entertaining guests (big shuffled playlists).
Comment by Sean Chavez (Isolinear) - Tuesday, 04 March 2008, 03:41 GMT
I also have this same problem, but have been unable to confirm anything consistent about why/when it happens or what causes it, only that it does indeed exist. I took a recording of the noise a couple of weeks ago but never got around to reporting it, then I searched again today and found that Humberto beat me to it.. :) I can tell you my recording sounds identical to the noise in Humberto's posted .mp3 file. It's quite painful, especially when listening to music loudly while driving.. Are we sure that it's specifically related to crossfading or is that only speculation?
Comment by harry tu (bookshare) - Tuesday, 04 March 2008, 03:42 GMT
I don't think it is pp related; I think it is ipod video specific. I have been using a pp target (ipod4g) since May 6 and a mini 2g from Jan. 15 to that date (all in 07). I have never experienced that problem in my rockbox life. I can resirect my ipod4g if needed, but I have switched 2 weeks ago to a new dap that doesn't support rockbox. :( I'll test if needed.
Comment by Humberto Santana (hhannah) - Tuesday, 04 March 2008, 04:18 GMT
@ Isolinear: About your question, actually the ONLY thing sure about this bug is that IT HAPPENS. No one has ever been able to make this noise happen at will... what makes it kind of like a "ghost", as I said... When I disable crossfading, it has not happened to me, but since I use crossfading MOST of the time, and have found many other ipod-rockboxers with this problem using crossfading [see the forums & flyspray links y placed at the end], y assume it is crosfading-related, or at least, that it tends to increase the number of times this bug happens. Also, since I mostly listen to my iPod using crossfade, I couldn't say that it does NOT happen having crossfade disabled. Has it happened to you without crossfade? What you say is very interesting, because the noise you get is EXACTLY the same... How often? What would be your settings? It also would be interesting if you could take a look in your iPod at debug menus I mention, and see if you get something similar.

@ Bookshare: as you say, I didn't find reports from people using other DAPs
Comment by Steve Bavin (pondlife) - Tuesday, 04 March 2008, 08:39 GMT
Does this still happen if you boost the CPU manually (i.e. so the CPU stays boosted throughout)? I wonder if it's related to the switching of CPU speed...
Comment by Humberto Santana (hhannah) - Tuesday, 04 March 2008, 14:14 GMT
Pondlife, not knowing about the technical details, I think on this one you might be on the right track very likely. I've observed that right before this problems occurs (view buffered thread in debug menu), pcm is very close to the top and the CPU begins to switch faster alternating 80Mhz and 30Mhz speeds (see 1.). What is the best way to boost the CPU manually??
Comment by Steve Bavin (pondlife) - Tuesday, 04 March 2008, 14:18 GMT
Go into System > Debug > CPU frequency and press UP a couple of times. You should see boost_counter increase. Then press left a few times to go back out to the menus and do some listening.

The battery will run down much faster when the CPU is boosted, so you may need to run powered too.
Comment by Humberto Santana (hhannah) - Thursday, 06 March 2008, 00:45 GMT
OK Pondlife, before I forget, thanks again for your interest... REALLY.
I'm doing what you suggest... still testing (so far results are not so clear)... I'll let you know when I do this longer
Comment by Humberto Santana (hhannah) - Saturday, 15 March 2008, 05:45 GMT
Pondlife, after a lot of testing and annoying noise hearing :/ ... finally I have some results for what you suggested. I did the following: Starting always in song # 1 in the same playlist, I increased the boost_counter the way you told me (to a value of 6), and waited for the noise bug to happen. One thing is for shure, it happened much faster than before (it used to happen after song #20 (approx. average?) of continuos crossfading; doing what you suggested made it happen mostly between songs 4-10. I hope this confirms where the problem is; however what I would have liked to report, was that using always the same settings, the same playlist starting in song #1, and increasing at the beginning of that song the boost count to 6, the noise bug would happen in the same place. However it isn't so. Anyway, I can confirm that doing that, made the problem happen much faster!
Comment by Humberto Santana (hhannah) - Friday, 28 March 2008, 20:56 GMT
IMPORTANT UPDATE

The crossfade problem, most likely, changed on a recent version. What happens now is that the iPod crushes during the crossfade process, freezing up and just showing "Data abort at 40000250 (0)" or "Data abort at 400002E0 (0)". THE SCREECHING NOISE, THOUGH, HAS APPARENTLY DISAPPEARED. Therefore, people that experience the crossfade problem from now on, might not identify it with this task.

The last version that I used experiencing the noise problem was r16507, but then I just jumped to version r16717, and since then the crossfade problem changed as I explained, even in the current version that includes viewports, etc.
Comment by Andree Buschmann (Buschel) - Saturday, 29 March 2008, 16:36 GMT
Seems like the issues are connected to buffer alignment (dword-aligned) while performing cross-fades. After applying this patch I could not reproduce the error after 30min of skipping each few seconds. Before applying the patch I could reproduce it nearly each dozen skips.
Comment by Andree Buschmann (Buschel) - Saturday, 29 March 2008, 18:01 GMT
This patch should also solve the stuttering when crossfading.

Loading...