Rockbox

Tasklist

FS#8660 - Recording hardlocks with keyclick enabled

Attached to Project: Rockbox
Opened by Corey DeLasaux (corey) - Thursday, 28 February 2008, 17:07 GMT
Last edited by Michael Sevakis (MikeS) - Saturday, 13 December 2008, 01:35 GMT
Task Type Bugs
Category Recording
Status Closed
Assigned To No-one
Operating System SW-codec
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Version 3.1
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

The Sansa e200 locks up in the record menu. To duplicate go into the record menu and move the wheel, skip fwd/bck, or select. Any action causes the unit to lock.
Attempted various settings in recording menu still same result (wav, mp3, diff bit rates, etc.)
Noticed this in the builds this week.

How do I get ahold of last weeks builds to find out where this was introduced?
This task depends upon

Closed by  Michael Sevakis (MikeS)
Saturday, 13 December 2008, 01:35 GMT
Reason for closing:  Fixed
Additional comments about closing:  Should be fixed in r19411. Buffer state is now checked before attempting use.
Comment by Corey DeLasaux (corey) - Thursday, 28 February 2008, 17:20 GMT
Opp's here's the current recording config.
Comment by Nils Wallménius (nls) - Thursday, 28 February 2008, 18:28 GMT
Check out this page http://www.rockbox.org/dl.cgi?bin=sansae200 it would be helpful if you could narrow it down to which day it started
Comment by Corey DeLasaux (corey) - Friday, 29 February 2008, 02:32 GMT
I found the cause sort of.
Going back in versions did not help so I I blew RB off the player and loaded the current build, which works great.
So I saved the configs of the defualt settings and compared with the settings I posted above.
I chaged one setting at a time and went to the record menu till it duplicated.

Setting "keyclick: weak" for some reason creates this lockup. Any setting other than off pretty much does it ;)

Regards and thank you for your time,
Corey
Comment by Michael Sevakis (MikeS) - Friday, 29 February 2008, 02:45 GMT
No suprise since trying to play back PCM through the pcm buffer while recording will definitely crash since the audio buffer is in use by recording exclusively. *sigh*
Comment by Corey DeLasaux (corey) - Friday, 29 February 2008, 03:35 GMT
Well that makes since, maybe a way to disable the click or any PCM while in the record menu.
Any way thanks for the help and should I put a request to close or do I just leave this ticket open?
Comment by Nils Wallménius (nls) - Friday, 29 February 2008, 13:06 GMT
We'll keep it open until the issue is fixed.
Comment by Steve Bavin (pondlife) - Tuesday, 04 March 2008, 08:49 GMT
Should the stuff in talk.c (talk_disable() and talk_temp_disable_count) be moved to pcmbuf and apply to all attempted audio output?

Loading...