Rockbox

Tasklist

FS#8664 - MP4/AAC Playback problems

Attached to Project: Rockbox
Opened by David Johnston (crashd) - Friday, 29 February 2008, 10:22 GMT
Last edited by Andree Buschmann (Buschel) - Wednesday, 17 November 2010, 18:48 GMT
Task Type Bugs
Category Codecs
Status Closed
Assigned To No-one
Operating System iPod 5G
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

When trying to play certain AAC/mp4 fles Rockbox will hang or become extremely sluggish, usually resulting in a necessary reboot. In all but on occassion, the audio stream hasn't begun.

Here's some examples :

http://pixelcorps.cachefly.net/twip/twip_002_aud.m4a
http://pixelcorps.cachefly.net/twip/twip_003_aud.m4a
This task depends upon

Closed by  Andree Buschmann (Buschel)
Wednesday, 17 November 2010, 18:48 GMT
Reason for closing:  Works For Me
Additional comments about closing:  Works for iPod Video, Clip+ and Fuze v1.
Comment by Magnus Holmgren (learman) - Sunday, 02 March 2008, 13:26 GMT
The first file (002) works fine on my Sansa e200, but the second one doesn't play at all. This is a known problem, where long MP4/AAC files will not play at all or possibly crash Rockbox. The reason is that the decoder runs out of memory, because it doesn't handle some data tables needed for playback and seeking in a very efficient manner (it pretty much reads the tables verbatim from the file).
Comment by Eliot (Yskyflyer) - Saturday, 23 August 2008, 04:19 GMT
I can reconfirm this bug still exists (iPod Video 60 Gig) r18335 clean install. 02 does’t play (codex error)* and 03 spins disk indefinitely. I accidently left to room and when I picked up my iPod I Burt my finger**.

*twip_002_aud.m4a
7fd5a580cc0b713b91599a05040e2425 (MD5sum On iPod)
f68ab251617d904a878c2f62925c6564 (Re download)
:. (File was corrupt)
**Dramatization. Though it was the hottest it’s ever been before.
Good luck with Version 3.0 Thanks everyone for the wonderful firmware.
Comment by Andree Buschmann (Buschel) - Saturday, 13 March 2010, 08:51 GMT
Retested both files on iPod Video 5.5G (32MB RAM) on r25137. Both files play fine, even though the disk activity is 2-3 times longer (20-25s) as normal (8-10s).
Comment by Leo Witt (some-xtc) - Thursday, 22 July 2010, 11:38 GMT
No problems with Clip+ & Fuze V1

Loading...