Rockbox

Tasklist

FS#8675 - Last song in playlist ends prematurely

Attached to Project: Rockbox
Opened by Richard Sweeney (riksweeney) - Monday, 03 March 2008, 13:54 GMT
Last edited by Magnus Holmgren (learman) - Tuesday, 04 March 2008, 18:56 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

The last song in the playlist ends a few seconds before it should do. This bug doesn't appear to be related to a player or codec.

Steps to reproduce

Reproduction is quite simple, find a track that has music up the the last second of the track. Highlight the song in Rockbox and do Context Menu -> Playlist -> Insert. You can fast forward to the last 20 seconds or so of the song to avoid having to listen to the entire thing.

You'll notice that the time remaining will say 2 seconds (roughly) and then the song will abruptly stop.
This task depends upon

Closed by  Magnus Holmgren (learman)
Tuesday, 04 March 2008, 18:56 GMT
Reason for closing:  Fixed
Comment by Steve Bavin (pondlife) - Monday, 03 March 2008, 16:55 GMT
This was caused by r16445 and should be fixed by the attached patch. Unfortuately I'm not experienced with bookmarks, so this will probably bring back the bug that r16445 was intended to fix...
Comment by Richard Sweeney (riksweeney) - Monday, 03 March 2008, 18:28 GMT
Cool, that solves the problem, but I guess it'll probably reopen the other bug...
Comment by Magnus Holmgren (learman) - Monday, 03 March 2008, 20:19 GMT
It would indeed reopen the bookmark bug. To fix that, after reverting 16445, the second Q_AUDIO_STOP command in codec_thread should only be sent if codec_load_next_track says it should be, i.e., in case the codec request failed. The codec thread shouldn't be too trigger happy when it comes to stopping playback...
Comment by Magnus Holmgren (learman) - Monday, 03 March 2008, 20:53 GMT
This patch reverts r16445 and then fixes the bookmark problem as I described above. Seem to work as intended in the simulator.
Comment by Steve Bavin (pondlife) - Tuesday, 04 March 2008, 17:34 GMT
Works for me (although I've not tested bookmarks). Magnus, I'll let you commit.

Loading...