Rockbox

Tasklist

FS#8689 - The peak meter does not work during a playing after a recording not followed by a reboot

Attached to Project: Rockbox
Opened by Roberto Penzo (roberto.penzo) - Thursday, 06 March 2008, 11:30 GMT
Last edited by Bertrik Sikken (bertrik) - Monday, 11 August 2008, 22:16 GMT
Task Type Bugs
Category Recording
Status Closed
Assigned To No-one
Operating System Archos Recorder
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

To reproduce it:

-I am using a Archos Jukebox Recorder v1;
-I am using 16500M (dated YYYY-MM-DD 2008-03-03) keeped on hard disc (i.e. not flashed);
-the boot OS is 1.17i (info readable on the very first screen after the power ON).

Steps:
-recall the Recording screen (you can see the Recording peak meter vell working)
-exit from the Recording screen
-go to Playing some Track
-on my machine the Peak meter does not work (my WPS does setting contains the tag %pm): it displays only the scale with the peak markers in some places, mot on run, without the signal bar.
-If I reboot by switching OFF and then ON the Archos and play again the track, the peak meter works as expected.

-By using, for instance, the Official Release 2.5, this bug is not present (i.e. the peak meter works just after the recording, without any need to switching OFF and ON).
This task depends upon

Closed by  Bertrik Sikken (bertrik)
Monday, 11 August 2008, 22:16 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed by  FS#9227  in r18249
Comment by Marc Guay (Marc_Guay) - Thursday, 06 March 2008, 19:12 GMT
Not reproducible on Sansa e200 + r16523.
Comment by Peter D'Hoye (petur) - Monday, 10 March 2008, 21:26 GMT
Marc, the archos is a HWCODEC player and uses other code than the sansa...
Comment by Markus Braun (mbr) - Thursday, 31 July 2008, 09:19 GMT
I can confirm this bug and have submitted a fix as  FS#9227 

Loading...