Rockbox

Tasklist

FS#8692 - Data abort at 00008140 (0)

Attached to Project: Rockbox
Opened by Sega (Sega) - Friday, 07 March 2008, 01:35 GMT
Last edited by Jonathan Gordon (jdgordon) - Tuesday, 24 June 2008, 07:30 GMT
Task Type Bugs
Category Operating System/Drivers
Status Closed
Assigned To No-one
Operating System iriver H10
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

On iRiver my H10 20gb, I just installed build r16543. After playing music through the database for about 5 minutes, I went change tracks and then this came up before the next song started playing:

Data abort at 00008140 (0)

And the screen froze with that message (and no music playing) before I had to do a hard reset.

I was using a build from last night earlier in the day and had no problems, so something must have changed since then to cause the error.
This task depends upon

Closed by  Jonathan Gordon (jdgordon)
Tuesday, 24 June 2008, 07:30 GMT
Reason for closing:  Fixed
Additional comments about closing:  hopefullly this has been fixed? repost if its still happening
Comment by Marc Guay (Marc_Guay) - Friday, 07 March 2008, 20:32 GMT
Can you reproduce the error or is it a random occurence? Random errors happen from time to time with any machine.
Comment by Sega (Sega) - Sunday, 09 March 2008, 01:43 GMT
I just got the exact same error (Data abort at 00008140 (0)) while playing music through the database with build r16582.
Comment by Vlado Plaga (vlado-do) - Sunday, 23 March 2008, 17:55 GMT
I have a similar problem with r16727-080321: "data abort at 400002E0 (0)" on my iPod nano when crossfading from vbr mp3 to ogg. It is reproducable with two specific files. I originally posted this as  FS#8787  (then still without having attempted to reproduce the crash).
Comment by Andree Buschmann (Buschel) - Sunday, 30 March 2008, 19:43 GMT
Vlado, your issue is solved with r16890.
Comment by Vlado Plaga (vlado-do) - Sunday, 30 March 2008, 20:57 GMT
Great! You are right, Andree, I just tested the current built with my "crash test" list and could no longer reproduce stuttering or crashes. Thank you for notifying me! Good work, Rockbox developers!

Loading...