Rockbox

Tasklist

FS#8773 - "Shuffle" button

Attached to Project: Rockbox
Opened by Mark (Xebozone) - Friday, 21 March 2008, 01:13 GMT
Last edited by Jonathan Gordon (jdgordon) - Sunday, 30 March 2008, 08:21 GMT
Task Type Feature Requests
Category Music playback
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

It would be cool if there was a "shuffle" button to quickly play music starting with a random track instead of going to the database, enabling shuffle, and pressing on a random song.

This would work like it does in the apple firmware
This task depends upon

Closed by  Bj√∂rn Stenberg (zagor)
Sunday, 30 March 2008, 08:21 GMT
Reason for closing:  Rejected
Additional comments about closing:  Closing all feature requests.
Comment by Paul Louden (Llorean) - Friday, 21 March 2008, 04:29 GMT
Are you aware of the quick-menu to easily turn shuffle off and on?
Comment by Mark (Xebozone) - Friday, 21 March 2008, 11:05 GMT
yes i am
Comment by Paul Louden (Llorean) - Friday, 21 March 2008, 11:11 GMT
So you're basically making a feature requests to save about 4 keypresses?
Comment by Mark (Xebozone) - Friday, 21 March 2008, 11:16 GMT
the problem isn't turning shuffle off/on

it would just be convinient if it could just to a "quick shuffle and play" instead of turning on shuffle, going to the database and selecting a song
Comment by Paul Louden (Llorean) - Friday, 21 March 2008, 11:18 GMT
Have you tried simply doing an "Insert Shuffled" on a category?
Comment by Mark (Xebozone) - Friday, 21 March 2008, 11:21 GMT
no...can you do it on the entire list of tracks?

Even so, that would still require going to the database 1st.

I don't know if you have ever used the apple firmware. If you have, you will notice how convinient it is to have a shuffle option on the main screen
Comment by Paul Louden (Llorean) - Friday, 21 March 2008, 11:25 GMT
You never mentioned it being on the main menu. Even if it's on the main menu, that doesn't increase the number of button presses it would save you, as you'd probably have to scroll down past the database to get to it anyway. It'd still only save you about 4 presses.
Comment by Marc Guay (Marc_Guay) - Friday, 21 March 2008, 14:24 GMT
You might find the "Play Selected First" setting useful if you don't want to randomly select the first song yourself. I think the basic response to this is going to be: Not everyone would use this feature (me, for example) and it would therefore clutter up the main menu for people who don't use it, and given that there are a variety of easy ways to do it otherwise, the negatives outweigh the positives.

Loading...