Rockbox

Tasklist

FS#8786 - Undefined instruction at 01F8001C (0) on e280

Attached to Project: Rockbox
Opened by cheese (cheeseboy001) - Sunday, 23 March 2008, 04:21 GMT
Last edited by Marc Guay (Marc_Guay) - Monday, 31 March 2008, 12:21 GMT
Task Type Bugs
Category Bootloader
Status Closed
Assigned To No-one
Operating System Sansa e200
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

When I boot with r16756 on my Sansa e280, after the rockbox logo shows I get the phrase "Undefined instruction at 01F8001c (0)" over the background from my theme, and have to hard restart (by holding down the power button).
I can still boot far enough to load the Sandisk firmware and go into USB mode.
This behaviour was not in r16543.
This task depends upon

Closed by  Marc Guay (Marc_Guay)
Monday, 31 March 2008, 12:21 GMT
Reason for closing:  Not a Bug
Additional comments about closing:  Isolated case, most likely corruption in the download or install process.
2008-06-09: A request to re-open the task has been made. Reason for request: I observed the same effect when upgrading. The problem was caused by the following line in the config.cfg: "start in screen: previous"
Comment by Marc Guay (Marc_Guay) - Sunday, 23 March 2008, 13:29 GMT
Does this happen every time you boot up or was it a one-off random occurrence?
Comment by cheese (cheeseboy001) - Sunday, 23 March 2008, 20:30 GMT
It happens every time I boot (although I've reverted to an older revision at the moment.)
The first time I booted, the database initialised before it crashed, but the rest of the times all I got was the logo, without text.
Comment by cheese (cheeseboy001) - Monday, 24 March 2008, 23:27 GMT
Is there an archive of old daily builds anywhere so I can try and narrow down where it was introduced?
Comment by Marc Guay (Marc_Guay) - Tuesday, 25 March 2008, 02:17 GMT
I also have a Sansa e200 and I update Rockbox very regularly and I do not have this problem. I suggest you try downloading a fresh current build, reinstall it, and try again. If this was a more general problem I think you'd hear an uproar from all the other users.
Comment by cheese (cheeseboy001) - Tuesday, 25 March 2008, 03:35 GMT
Okay, I deleted the .rockbox folder (after backing it up), put the new one on, and it worked. After a while, I narrowed it down to two files (nvram.bin and folder_advance_list.dat), neither of which are in the latest build and both of which make a crash on boot. With just folder_advance_list.dat I get "Data abort at [address I didn't note]" and with nvram.bin I get the original one (though the address varies between builds). Even after deleting both files, the error remains. Deleting the files in the .rockbox folder excluding subfolders doesn't fix it. Only putting the .rockbox directory from r16543 on or deleting the entire .rockbox folder and putting the new one on seems to remove the error.
Comment by Marc Guay (Marc_Guay) - Tuesday, 25 March 2008, 12:02 GMT
I'm pretty sure you just had a currupt download and/or install.

Loading...