Rockbox

Tasklist

FS#8855 - New Backlight Mode

Attached to Project: Rockbox
Opened by Steve (TheBashar) - Sunday, 06 April 2008, 18:20 GMT
Last edited by Marc Guay (Marc_Guay) - Sunday, 06 April 2008, 18:49 GMT
Task Type Feature Requests
Category LCD
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I would like to develop an additional backlight activation mode. This new mode would operate similarly to the existing "first button press activates backlight only" option. The difference is that when on the WPS (and only on the WPS) button presses which have an immediate action effect would not trigger the backlight but instead cause their action. This would be track skip, track un/pause, volume change. All other buttons would operate like the first button press activates backlight only option. While immediate action buttons would perform their action without activating the backlight, their press would reset the backlight off timer should the backlight already be activated.

My intention with this feature request is to solicit comment before trying to gen up a patch in the next couple weeks.
This task depends upon

Closed by  Björn Stenberg (zagor)
Sunday, 06 April 2008, 18:49 GMT
Reason for closing:  Duplicate
Additional comments about closing:  Closing all feature requests.
Comment by Steve (TheBashar) - Sunday, 06 April 2008, 18:31 GMT
Thanks, Marc. I had searched the feature requests but I didn't think to search the patches. This is definitely a dupe of FS#8400.

Loading...