FS#8897 - log settings not saved (can't turn logging on)

Attached to Project: Rockbox
Opened by daniel (dannyq) - Tuesday, 15 April 2008, 17:53 GMT
Last edited by Steve Bavin (pondlife) - Wednesday, 16 April 2008, 08:04 GMT
Task Type Bugs
Category Configuration
Status Closed
Assigned To No-one
Operating System iPod 5G
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


1. Go to settings and enable the log, click 'yes'.
2. Notice/Alert states: 'reboot to enable'
3. I reboot. log is not enabled. No .scrobbler.log exists.

I have deleted the .rockbox directory and re-unzipped the most recent build, but the problem persists. So I think this is a bug and not a file-permissions problem, but I can't reproduce it because I only have one ipod.
This task depends upon

Closed by  Steve Bavin (pondlife)
Wednesday, 16 April 2008, 08:04 GMT
Reason for closing:  Not a Bug
Comment by Michael DiFebbo (medifebbo) - Tuesday, 15 April 2008, 18:11 GMT
How are you rebooting? To do so properly, you should shut down the player by pressing and holding the Play button until the player shuts down, and then turn the player on again.
Comment by daniel (dannyq) - Wednesday, 16 April 2008, 07:22 GMT
I always reboot using menu+select. I didn't know it could be done by holding play/pause; so that was probably the problem. I let the timeout switch the ipod off and the setting caught.

Sorry for my ignorance, and thanks for the help :)