Rockbox

Tasklist

FS#8901 - iPod Mini will not boot with CF

Attached to Project: Rockbox
Opened by Felix (ph33lix) - Wednesday, 16 April 2008, 06:56 GMT
Last edited by Nils Wallménius (nls) - Sunday, 21 December 2008, 23:56 GMT
Task Type Bugs
Category Bootloader
Status Closed
Assigned To No-one
Operating System iPod Mini
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Version 3.1
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Hi, I am new to this Rockbox thing and am very very interested in installing it in my iPod Mini 1st Gen because of the parametric EQ function which I would really like.

However, after installing the firmware fonts and bootloader (be it automated via rockbox utility or manual) I find myself waiting very long for the iPod to boot. And when it finally gets past the Apple splash screen, I get an error message saying that a partition is not found (ATA: -80 Partition not found).

I have recently swapped out the ailing 4GB Hitachi microdrive with a Transcend 4GB solid state CF card.
Does rock box have a problem with any CF card other than the Hitachi microdrive?
This task depends upon

Closed by  Nils Wallménius (nls)
Sunday, 21 December 2008, 23:56 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed quite a while ago with the 3.0 bootloader release.
Comment by Nils Wallménius (nls) - Wednesday, 16 April 2008, 12:03 GMT
If you know how to build your own bootloader it would be interesting to know if one built from current svn would work. Because fixes for booting from cf cards have been committed but I fear no new bootloader has been released since.
Comment by Dominik Riebeling (bluebrother) - Wednesday, 16 April 2008, 19:44 GMT
I've just build a bootloader from current svn and attached it. The released bootloaders are dated september 2007, so they definitely don't include the CF fixes. As I don't own a mini1g the bootloader isn't tested, use at your own risk (but as we know you can't brick your Ipod by installing the bootloader ;-)
Comment by Felix (ph33lix) - Thursday, 17 April 2008, 06:04 GMT
Thanks for the swift responses guys.
Don't mind me asking though, just how do I go about loading this bootloader into my ipod?

Thanks again.
Comment by Dominik Riebeling (bluebrother) - Thursday, 17 April 2008, 06:07 GMT
ipodpatcher --add-bootloader bootloader-ipodmini.ipod

(ipodpatcher --help can be quite useful ;-)
Comment by Felix (ph33lix) - Thursday, 17 April 2008, 06:16 GMT
When I try typing "ipodpatcher --add-bootloader bootloader-ipodmini.ipod" or "ipodpatcher --help" the program seems to just read the "i" in the above two commands and installs its internal bootloader.
Am I missing something?
Comment by Dominik Riebeling (bluebrother) - Thursday, 17 April 2008, 19:28 GMT
errr ... you're starting ipodpatcher with the given line from the command line (i.e. cmd.exe on windows), you're not starting it by clicking it and typing the line in the window that opens after that?
Comment by Felix (ph33lix) - Friday, 18 April 2008, 02:57 GMT
I doubleclicked on the ipodpatcher.exe and all I could enter was either i, u or c.
Any other command like, --help or --add-bootlader bootleader-ipodmini.ipod, will cause it to exit. And any commands that start with "i" like, ipodpatcher --... , will cause the program to install its internal bootloader.

I've been reading up on the developers page and notes about all this, but any additional help in pointing to the right direction would definitely help.
Comment by Dominik Riebeling (bluebrother) - Friday, 18 April 2008, 05:52 GMT
ipodpatcher is a command line application. It always worked this way. You NEED to start it from the command line and add the options there. The behaviour to keep the window open and give the user three choices was only added for convenience. You CAN'T enter a command line if you started ipodpatcher itself, as ipodpatcher is not a command line.

1. Click "Start"
2. Click "run" (maybe hidden below "all applications". Look for it)
3. type "cmd.exe"
4. a black window opens (the cmd box). It looks like the window ipodpatcher opens but stays open.
5. the window has a prompt that includes a path, something like "C:\Documents and Settings\user"
6. open "My Computer". Browse to the path that is displayed in 5.
7. put the two files ipodpatcher.exe and boodloader-ipodmini.ipod into this location
8. now type in the black window "ipodpatcher --add-bootloader bootloader-ipodmini.ipod". Press the enter button. It will install the bootloader file.
9. to close the black window, type "exit", followed by a press of enter.
10. You can remove / move back / delete the two files you copied in 7. afterwards.
Comment by Felix (ph33lix) - Friday, 18 April 2008, 10:41 GMT
Oh wonderful! It works now.
Thanks heaps to you, dominik. You've been a great help.

This ipod now has a new lease of life.
Comment by Dominik Riebeling (bluebrother) - Friday, 18 April 2008, 16:30 GMT
well, one question remains (as you unfortunately haven't answered it directly): do I take you correct that the issue is now fixed?
Comment by Felix (ph33lix) - Saturday, 19 April 2008, 05:13 GMT
Yes it is fixed. Do I have to request closure for this topic?
I didn't realise I had to go through the cmd route.
Thanks for the patience anyway.

Anyway, I find that rockbox is a wee bit unstable, will try experimenting with it more on my own now.
:)
Comment by Nils Wallménius (nls) - Saturday, 19 April 2008, 07:17 GMT
I think we should keep this open until a new bootloader is released.
Comment by sirio balmelli (sirio.bm) - Saturday, 03 May 2008, 13:31 GMT
Hello. I am also very interested in this, although unsure if this is the correct thread to write on.

I have a 1G Mini which belongs to a friend of mine. They turned it in after the HD (4GB microdrive) was thoroughly destroyed by a drop. (no way to even read the thing, even when I took it out and connected it to a CF slot on my linux box).

I bought an 8GB card. Ipod Diagnostics shows the R/W and scan tests pass - they also see that the card is 8G, so no prob there. Also, when I hook this thing up to any O/S (Win, Lin, Mac) the ipod shows up as a drive and I can read and write to this drive to my heart's content (fdisk, dd, mkdosfs).

As far as Itunes goes, the ipod is in an endless restore loop. There are no probs restoring the firmware, and even after I zero out the entire disk (not partition - device) with dd, it restores nice new partitions with the proper tags etc. But the iPod simply gives the !folder icon on boot despite all. It DOES NOT ask for external power, it simply reboots and shows the folder icon.

This leads me to say that the problem lies with the IPOD BOOTLOADER in flash. A search to find how a firmware update proceeds confirms this: the ipod, upon booting, finds a new firmware image and then executes an update of it's internal flash memory. Before it goes ahead and does this, it asks you to plug it into outlet power if you have not already done so. If you get the folder icon, the Ipod bootloader never managed to read the firmware, or the disk for that matter.

The solutions I have found to this are to get the old Microdrive, boot into that, update the firmware to 1.4.x and then switch out to CF, which the bootloader will then have no problem with whatsoever. The problem lies with the "old microdrive" part, since this thing sounds like a rattlesnake when it boots up and there is no way of getting it to read or write.

Since I wanted to install rockbox anyways, I decided to go ahead and manual install as per the docs, but replace the bootloader with the one you publish above (thx Dominik!). The dreaded folder icon once again made it's appearance.

Do any of you know how to get around this? Since what I want is rockbox anyways, it's kind of useless to mess around with Apple (5R's anyone?) and alls I need to solve is this itty bitty flash problem on an otherwise good player.

Thx for the help.




Comment by Felix (ph33lix) - Sunday, 04 May 2008, 03:50 GMT
I find myself in that situation many times too, sirio.
I find that it helps to disconnect the battery altogether and let it sit for a while, maybe about 10 minutes should do the trick.

Everytime I do that, I'll be able to restore my Ipod properly.

However, for my case, I seem to find my file system killing itself after a while. Like I'd restore it successfully and synced some songs in and by day's end, my music would all just disappear (like it'll skim through the playlist real fast and no audio playback) and I'll get the folder with exclamation mark error after reboot.
Comment by Humberto Santana (hhannah) - Monday, 14 July 2008, 22:15 GMT
I recently compact-flashed an iPod mini 2nd gen using a 32GB Transcend 133x CF card, then installed Rockbox using a bootloader I found in the forums by Dominik Riebeling (Danke SEHR bluebrother!), and it's working just perfectly. Thought it'd be a good idea to make the bootloader for the 2nd gen mini also available here.
Comment by Yu Ru (robinyru) - Friday, 28 November 2008, 22:21 GMT
I will try the bootloader for ipod mini 2nd too. Thanks.
Comment by Nils Wallménius (nls) - Saturday, 29 November 2008, 08:45 GMT
Yu Ru, please test the official bootloader instead, a new one has been released which has the fix for this issue.

Loading...