Rockbox

Tasklist

FS#8926 - Shutdown with error codes while playing "Spacerocks"

Attached to Project: Rockbox
Opened by TRW (StarSkeptic) - Wednesday, 23 April 2008, 01:29 GMT
Last edited by Nils Wallménius (nls) - Saturday, 04 October 2008, 23:00 GMT
Task Type Bugs
Category Games
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Shutdown while playing spacerocks, 2 to 3 levels in with alternate error codes:

"Data Abort at E8000088 (0)"

"Data Abort at 0004E660 (0)"

"Undefined Instruction at 0006E6A4 (0)"

also sluggish response when browsing files.

Somewhere around version 17202--sorry that's a guess..

going back to 16980 fixed this..

thanks...TRW
This task depends upon

Closed by  Nils Wallménius (nls)
Saturday, 04 October 2008, 23:00 GMT
Reason for closing:  Fixed
Comment by William (lee321987) - Saturday, 26 April 2008, 12:12 GMT
On me it's either freezing, or suddenly displays the OF's boot screen, and just stays on that screen -- accepting no input, but a LONG power-off button hold.
Player: Sansa c200
RB Version: r17251M-080426
(I'm also using the patch that adds a scroll bar to the graphic EQ --  FS#7916 )

Comment by William (lee321987) - Monday, 28 April 2008, 08:12 GMT
I was reminded not to report bugs on modified builds, so I just wanted to say that I ran a clean build, and am still crashing. Oh, and if this helps I have crashed it over 15 times, and only once was I able to see an error code.
Comment by Jeff Yeo (jwyeo2) - Saturday, 03 May 2008, 04:32 GMT
I am seeing this problem on a Sansa e250 with rockbox build 17232. No error codes, but I've had it lock up and require a long power-off hold to reset.
Comment by Jeff Yeo (jwyeo2) - Sunday, 04 May 2008, 17:28 GMT
Running spacerocks in the uisimulator will eventually result in a segmentation fault. I'm not sure how to get more helpful info ...

simulator rockbox-info.txt
------------------------------
Target: e200
Target id: 23
Target define: -DSANSA_E200
Memory: 32
CPU: arm
Manufacturer: sandisk
Version: r17347-080504
Binary: rockboxui
Binary size: 1826539
Actual size:
RAM usage: 0
Features: backlight_brightness:dircache:flash_storage:hold_button:lcd_bitmap:lcd_non-mono:lcd_color:lcd_flip:lcd_invert:lcd_sleep:pitchscreen:quickscreen:radio:recording:recording_swcodec:rtc:scrollwheel:swcodec:tagcache:tc_ramcache:charging:usb_charging
gcc: gcc (GCC) 4.1.2 (Gentoo 4.1.2 p1.0.2)
ld: GNU ld (GNU Binutils) 2.18
Host gcc: gcc (GCC) 4.1.2 (Gentoo 4.1.2 p1.0.2)
Host system: Linux
Comment by Jonathan Gordon (jdgordon) - Tuesday, 19 August 2008, 13:07 GMT
this looks like stack corruption somehow...
I've narrowed it down to line 1711, but thats as far as I got
Comment by Teruaki Kawashima (teru) - Tuesday, 02 September 2008, 05:40 GMT
I think this patch fixes this problem..
Comment by Frank Gevaerts (fg) - Monday, 08 September 2008, 16:33 GMT
That looks very unlikely to me to be the correct fix. It may help finding the real problem though
Comment by Frank Gevaerts (fg) - Monday, 08 September 2008, 19:50 GMT
This seems to happen on all colour ARM based players (seen on ipod video, ipod photo, c200, e200, gigabeat f, H10). It doesn't happen on coldfire (tested on h100, h300, x5, but those have  FS#9380  which may have the same cause) or on non-colour players (tested on ipod mini)
Comment by Nils Wallménius (nls) - Friday, 03 October 2008, 08:32 GMT
Hi i committed a fix to the lcd driver (which turned out to be identical to Teruaki's patch, sorry, should have checked the tracker better) anyways this should be fixed in r18691. If someone wants to try it out and report i would appreciate it.
Comment by jon (gilbert necessary) - Saturday, 04 October 2008, 08:24 GMT
hello nils -- I have just downloaded latest version and spacerocks seems to be up and running! i have gotten to stage 3 no problem, but I keep getting killed (i am crap at spacerocks but I love it) so I dunno if it crashes afterwards. In the past it always froze early on so it looks like the problem may be fixed! cheers.
Comment by TRW (StarSkeptic) - Saturday, 04 October 2008, 14:36 GMT
Mine's working! (iPod video)---thanx

Loading...