Rockbox

Tasklist

FS#8939 - RButil should be able to wipe and start from scratch

Attached to Project: Rockbox
Opened by Richard Neill (RichardNeill) - Sunday, 27 April 2008, 03:30 GMT
Last edited by Alex Parker (BigBambi) - Sunday, 27 April 2008, 17:29 GMT
Task Type Feature Requests
Category Rbutil
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Roxbox Utility doesn't have the ability to initialise a corrupted iPod, or start from scratch. I'd like to start with dd if=/dev/zero of=/dev/sdg, and then have rbutil do everything from there.

I don't want any apple firmware on the ipod at all, (and having lost it, I don't really want to bother locating a new copy) but ipodpatcher quits with "[ERR] Firmware partition doesn't contain Apple copyright, aborting." This seems to be a safety check so you don't accidentally trash some other disk - but it makes it impossible to install *just* rockbox on the ipod.

This task depends upon

Closed by  Bj√∂rn Stenberg (zagor)
Sunday, 27 April 2008, 17:29 GMT
Reason for closing:  Rejected
Additional comments about closing:  Closing all feature requests.
Comment by Dominik Riebeling (bluebrother) - Sunday, 27 April 2008, 13:42 GMT
1. I've changed the task to a feature request, as this clearly isn't a bug -- it's working the way it is intended.
2. I disagree that this should be something rbutil supports -- rbutil is intended for end users, and removing such safety checks will only cause trouble.
3. checking for the apple firmware is _needed_ to find the correct drive. As the bootloader installation requires raw disc access you can't simply detect that from a mountpoint.
4. you can replace the apple firmware completely with the Rockbox bootloader using ipodpatcher. As this is something the average end user usually won't want to do this is nothing rbutil should include. At least until we have some extra "expert mode" (if we ever get that).
5. If you simply wipe the complete disc you won't be able installing Rockbox at all as you need to have the data partition formatted.
6. I haven't rechecked it, but I AFAIK the apple bootloader (which is in flash and runs always) checks the disc layout. If it doesn't find the correct one it tells to contact support. Not sure if it checks for the copyright notice too.
7. rbutil is an installer tool for Rockbox and not intended to repair corrupted players.

To sum it up, IMO this is nothing rbutil should be able to do. If you use dd to wipe your player you can also use ipodpatcher.
Comment by Richard Neill (RichardNeill) - Sunday, 27 April 2008, 15:17 GMT
1. I do mostly agree that this is a feature request, though some aspects of it are bug-related.
2. Agreed - the safetys are a good thing by default, but they should be over-ridable.
3. I'd like to be able to say explicitly that /dev/sdX is the ipod.
4/5. Why not give the option to do this? Except for initial evaluation of Rockbox, dual-booting is pretty useless on an iPod! After all, once I have a directory full of oggs, and no iPod database, the apple firmware is useless anyway. ipodpatcher does not allow you to do anything if it can't find the copyright notice, so if you start with a corrupted ipod, clear it, and fdisk it to set the partitions correctly, ipodpatcher still won't install the bootloader. There's no way to skip the checks!
6. I think the partition layout is required, but the copyright notice may not be. Besides, can't we fake the copyright notice without needing apple's firmware.

I do realise that my request is not for the majority, but quite a lot of people will want to have a pure-rockbox system. This is like installing Linux on a windows machine - many people opt to completely overwrite the disk.

Lastly, if you do turn out to have a corrupted player, rbutil's messages aren't exactly helpful.

Comment by Alex Parker (BigBambi) - Sunday, 27 April 2008, 15:37 GMT
1) Which parts are bugs?

2) I'm not convinced they should be (able to be overridden that it). When it is possible some people will find a way to do it by mistake, and this is meant for new users and should, IMO, be completely safe (or as safe as replacing a firmware can be).

4) "Except for initial evaluation of Rockbox, dual-booting is pretty useless on an iPod!"

Rockbox does not yet have a USB mode, and on some iPods the emergency disk mode is horribly slow, therefore the OF is still very desirable for USB transfers on these.

Also, on iPod Videos, the video playback is much better in the OF than Rockbox. People may also want to play iTunes bought music, etc etc. Just because you don't, please don't assume no-one has any further use for the OF.
Comment by Dominik Riebeling (bluebrother) - Sunday, 27 April 2008, 15:53 GMT
1. I disagree that "some aspects" should be bug-related. It's not a bug in Rockbox or rbutil to behave as designed, and it's not a bug if your OF is wiped. If you still think something is bug-related please tell me which bug you are referring to.
2. feel free to post a patch against ipodpatcher ;-)
3. That's nothing that should be in rbutil because it has a different intention. You can do this with ipodpatcher. As I said before, if you're using dd you can as well use ipodpatcher directly -- you're leaving the "main" path, and rbutil is the mainstream tool.
4. I disagree. Quite a few people will want to dual-boot and in fact we recommend using the OF for videos on the Ipod Video if users want to play other files than mpegplayer supports (like videos podcasts and videos from Itunes Music Store).
5. Formatting the drive is nothing that rbutil should do. It's an _installer_, not a repair tool.
6. You can fake the copyright notice easily yourself. You could also adapt ipodpatcher to allow disabling the copyright notice check.

And I really don't think "quite a lot of people will want to have a pure-rockbox system". This might be true for non-ipods, but as one can clearly see from the support channels quite a lot of people want dual-boot. Your comparison to a linux box also isn't a good example -- quite a lot of people chose to dual-boot (I'm doing that myself for years, even if windows is running rarely on my box; and I know some guys almost exclusively running linux but still preserving the windows partition on their boxes. The MS tax has been paid anyway ...)

I agree that the error messages in rbutil could be better, but that's a general thing and something that is in focus during the ongoing work anyway. Besides, it's quite hard to detect an Ipod if you can't detect it -- and tell the user the Ipod is broken. Detection of the Ipods is purely based on the OF disc layout. Detecting the Ipods purely based on USB IDs isn't possible due to some VIDs not being unique.
Comment by Dave Chapman (linuxstb) - Sunday, 27 April 2008, 15:53 GMT
The checks that ipodpatcher (and therefore rbutil, as they both share the same code) are more than just for safety.

ipodpatcher is designed to modify an existing Apple firmware partition, not create one from scratch. This was a deliberate decision in order to keep ipodpatcher as simple as it possibly can be (it is already relatively complex) - I wouldn't want to go away from that, when it there are many methods of restoring a broken ipod, without the need to add that ability to ipodpatcher.

Comment by Richard Neill (RichardNeill) - Sunday, 27 April 2008, 16:06 GMT
> Rockbox does not yet have a USB mode, and on some iPods the emergency disk mode is horribly slow, therefore the OF is still very desirable for USB transfers on these.

I didn't know that. I've always used the emergency disk mode. Thanks for the info.

> Just because you don't, please don't assume no-one has any further use for the OF.

Sorry - that's not what I'm suggesting. What I am saying is that there are some people (fraction unknown) who don't need the OF.

Anyway, it seems that no-one is going to do this, so feel free to close this bug.

BTW, thanks very much for all your work - Rockbox is great, and it turns the iPod from an ogg-incompatible, directory-tree-unfriendly brick into the best music player! It's a shame that there's no way to get it to work on the newer machines (is this simply impossible, or just "a hard problem that no-one has solved yet"?)

Loading...