Rockbox

Tasklist

FS#8964 - Starting last track in an album with repeat off keeps CPU boosted

Attached to Project: Rockbox
Opened by Bertrik Sikken (bertrik) - Monday, 05 May 2008, 19:20 GMT
Last edited by Nicolas Pennequin (nicolas_p) - Wednesday, 02 July 2008, 21:54 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To Nicolas Pennequin (nicolas_p)
Operating System Sansa e200
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Hardware setup: sansa e260 with svn17390

How to reproduce:
* make sure that repeat is off (used the quickscreen to disable it)
* in the database browse to an album and start the last song
* go to debug menu / buffering thread and observe the boost ratio:
-> boost is at 100% regardless of pcm level
-> CPU stays boosted even after songs ends

This does not seem to be related to a specific album.
This task depends upon

Closed by  Nicolas Pennequin (nicolas_p)
Wednesday, 02 July 2008, 21:54 GMT
Reason for closing:  Fixed
Additional comments about closing:  r17923
Comment by Bertrik Sikken (bertrik) - Friday, 16 May 2008, 10:33 GMT
Possibly related to  FS#8999 
Comment by Bertrik Sikken (bertrik) - Sunday, 29 June 2008, 12:08 GMT
Still present in svn 17875
Comment by Nicolas Pennequin (nicolas_p) - Tuesday, 01 July 2008, 09:21 GMT
Here is a patch that fixes the issue. I've tried to commit it but couldn't due to a crappy internet connection.
From my testing it seems OK, but please try it too!
Comment by Bertrik Sikken (bertrik) - Tuesday, 01 July 2008, 09:38 GMT
It fixes the problem for me too.

Loading...