Rockbox

Tasklist

FS#8992 - Bass & Treble Not Rendered By Player Every Restart

Attached to Project: Rockbox
Opened by Nikkhil (AceNik) - Thursday, 15 May 2008, 00:44 GMT
Last edited by Nils Wallménius (nls) - Saturday, 17 May 2008, 07:22 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System SW-codec
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

In this bug the bass & treble settings have no effect on the player or the player seems to ignore the values on every restart & resume of playback. I have spotted the bug on h10[20GB] but by discussing on the IRC, it seems this bug would be affecting all the SW-codec players.

Steps to reproduce the bugs are so:
1.Hope You have equalizer on, bass & treble already set at a value.
2.Restart the player.
3.Resume playback.
4.Just reapply the bass value & treble value after that notice the volume difference.

Note:
This Bug did get fixed i think in the revision below but only on a particular platform
r17478: hopefully fix problems with setting bass/treble on wm8751 targets (mrobe100,...)

Well im using r17518 now & this bug still exists, but i belive the bug started at r17214 or r17217
This task depends upon

Closed by  Nils Wallménius (nls)
Saturday, 17 May 2008, 07:22 GMT
Reason for closing:  Fixed
Comment by Nils Wallménius (nls) - Thursday, 15 May 2008, 00:57 GMT
I have found one issue introduced in r17274 in sound.c
in both sound_set_treble() and sound_set_bass() dsp_callback is called before the
current_bass/current_treble is calculated so this will always be 0 on the first call.

I don't know if this is the cause of this bug and I can't test it as I don't have an affected target.
Comment by Steve Bavin (pondlife) - Thursday, 15 May 2008, 08:33 GMT
Ah, does it only happen if EQ is enabled? I tested (without EQ) on my H300 yesterday and it seemed fine. I'll try again tonight with EQ enabled.
Comment by Lee Kang Hyuk (alwaysbluepop) - Thursday, 15 May 2008, 15:40 GMT
I have a same issue on my x5, and confirmed that r17274 caused the trouble.
Setting up the current_value prior to dsp_callback fixed this problem.

Loading...