Rockbox

Tasklist

FS#9002 - Bootloader on c200 shows "target id: e200"

Attached to Project: Rockbox
Opened by Thomas Martitz (kugel.) - Saturday, 17 May 2008, 14:58 GMT
Last edited by Bertrik Sikken (bertrik) - Monday, 14 July 2008, 15:54 GMT
Task Type Bugs
Category Bootloader
Status Closed
Assigned To No-one
Operating System Sansa c200
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

You can see this when pressing the button to boot into OF, so that the text is shown.

The cause is sansapatcher.

In line: 608
/* Add Rockbox-specific header */
memcpy(buf+0x1f8,"RBOFe200",8);

It adds this string to the mi4header. The bootloader identifies the model by that string.

gevaerts spotted that line.
This task depends upon

Closed by  Bertrik Sikken (bertrik)
Monday, 14 July 2008, 15:54 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in r18035
Comment by Bertrik Sikken (bertrik) - Thursday, 10 July 2008, 22:04 GMT
I see this too on my c240
Comment by Bertrik Sikken (bertrik) - Monday, 14 July 2008, 09:33 GMT
Attached patch fills in the correct target name. Tested on my sansa c240 and e260.

Loading...