Rockbox

Tasklist

FS#9010 - checkwps warnings

Attached to Project: Rockbox
Opened by Thomas Martitz (kugel.) - Sunday, 18 May 2008, 20:44 GMT
Last edited by Nils Wallménius (nls) - Monday, 19 May 2008, 14:37 GMT
Task Type Bugs
Category Themes
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

When building checkwps I receive several warnings, they are all the same though. The warning just pops up for each target.

../../apps/gui/wps_parser.c: In function 'wps_data_load':
../../apps/gui/wps_parser.c:1530: warning: cast to pointer from integer of different size

This is caused by line 1530 in wps_parser.c, which is this:

char *wps_buffer = (char *)plugin_get_buffer(&buffersize);

Changing this line to e.g.
char *wps_buffer = (char *)((long)plugin_get_buffer(&buffersize));
kills the warnings.

Note: I'm on a 64bit system, this is most likely the reason.
This task depends upon

Closed by  Nils Wallménius (nls)
Monday, 19 May 2008, 14:37 GMT
Reason for closing:  Fixed
Additional comments about closing:  fix committed in r17582

Loading...