Rockbox

Tasklist

FS#9048 - ipod 5.5g freezes upon usb connection on off state

Attached to Project: Rockbox
Opened by glen (glenmo) - Wednesday, 28 May 2008, 16:35 GMT
Last edited by Steve Bavin (pondlife) - Monday, 01 September 2008, 08:19 GMT
Task Type Bugs
Category Bootloader
Status Closed
Assigned To No-one
Operating System iPod 5G
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Version 3.0
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

when my 5.5gen ipod is off, i connect it to the computers (winXP desktop and laptop, Ubuntu desktop) expecting to have it boot into usb drive mode, but it comes up to rockbox environment and freezes.

i think it is still charging when frozen.

r17644 build. i think it started in r174xx build.
This task depends upon

Closed by  Steve Bavin (pondlife)
Monday, 01 September 2008, 08:19 GMT
Reason for closing:  Fixed
Additional comments about closing:  Clossure was requested as this was fixed sometime beween r17644 and r17729.
Comment by glen (glenmo) - Saturday, 21 June 2008, 18:56 GMT
let's reopen this -- i made a mistake in requesting closure

using 17746 now and it's doing it.

if the device is off and i plug it into usb, device freezes at home screen (files, database, resume playlist...) and i have to force restart in order to get it back to usable state. it will only load usb transfer mode if the device is turned on when i plug it into usb. this was not always the case and i found it very convenient to not have to worry whether or not it was powered up before plugging it in...
Comment by Jon (lemonman) - Sunday, 13 July 2008, 05:22 GMT
Same here on my 5.5G 30gig. It's been doing this forever, and it's kind of annoying.
Comment by federico pelupessy (fip) - Wednesday, 20 August 2008, 18:43 GMT
I can confirm this, and add some info:

- it seems to be related to the directory caching, because turning dir cache off lets the USB connect.
- putting a sleep command just before init_dircache (but after usb_start_monitoring) solved the problem with dir cache on, but obviously this is not a real fix.
(HZ is the minimum wait time that seems to fix it, HZ/2 doesn't)

Loading...