Rockbox

Tasklist

FS#9098 - WPS isn't cleared before displaying "Shutting down" splash

Attached to Project: Rockbox
Opened by Marc Guay (Marc_Guay) - Tuesday, 17 June 2008, 11:57 GMT
Last edited by Jonathan Gordon (jdgordon) - Monday, 23 June 2008, 02:46 GMT
Task Type Bugs
Category User Interface
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Sansa e200 & r17727

As the title states, parts of the WPS aren't being cleared before the "Shutting down" splash is being displayed. At first I thought it was just the foreground items which would remain, but testing with cabbiev2 shows that the background also does not clear sometimes.

Recipe:
- Go to the WPS screen
- Shut down
This task depends upon

Closed by  Jonathan Gordon (jdgordon)
Monday, 23 June 2008, 02:46 GMT
Reason for closing:  Fixed
Comment by Steve Bavin (pondlife) - Tuesday, 17 June 2008, 13:18 GMT
Hi Marc,

I might be misunderstanding, but I thought the splash should appear on top of whatever else is displayed anyway and I don't see why clearing should be needed. Having said that, when I try it here, the (default) WPS clears apart from the backdrop, so you have a black backdrop with the vertical/grey Rockbox logo. It would look odd IMHO if this backdrop were to vanish.
Comment by Marc Guay (Marc_Guay) - Tuesday, 17 June 2008, 13:28 GMT
Strange, are you using the same revision? I can consistently get it to display only seemingly random pieces of the WPS when the splash screen comes up. I can't recall the previous behavior, but as it stands now it looks very odd.
Comment by PaulJam (PaulJam) - Tuesday, 17 June 2008, 14:20 GMT
Hi,

this seems to happen only when "fade on stop/pause" is enabled.
maybe this is related to the changes in r17723.
Comment by Marc Guay (Marc_Guay) - Tuesday, 17 June 2008, 14:28 GMT
Good call Paul. I switched the fading on to check out the bug fix and didn't consider that having it on might be the cause of this.
Comment by Alexander Levin (fml2) - Sunday, 22 June 2008, 09:54 GMT
Just wanted to say that the bug still exists in r17749 (at least on sansa e200).

Loading...