Rockbox

Tasklist

FS#9123 - Left joystick action to sensitive

Attached to Project: Rockbox
Opened by Joaquim Dias (dunno) - Thursday, 26 June 2008, 13:59 GMT
Last edited by Marc Guay (Marc_Guay) - Friday, 12 December 2008, 14:40 GMT
Task Type Feature Requests
Category User Interface
Status Closed
Assigned To No-one
Operating System Iriver H100 series
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

H140; Filetree browsing,

When browsing through my music collection if I want to go back one level a quick left joystick click is required, the problem is that this has to be really quick, if the left action is slightly longer than "quick" the left click action then takes the browser to root, this is annoying as the intention was to only go back one level, could the time delay for left click back to root be increased please ?.
This task depends upon

Closed by  Bj√∂rn Stenberg (zagor)
Friday, 12 December 2008, 14:40 GMT
Reason for closing:  Invalid
Additional comments about closing:  Closing all feature requests.
Comment by Paul Louden (Llorean) - Thursday, 26 June 2008, 21:01 GMT
This sounds more likely to be a hardware fault.

But to be clear, you haven't posted what revision you've tested this on.
Comment by Joaquim Dias (dunno) - Friday, 27 June 2008, 06:55 GMT
I'm using the latest revision.

My H140's joystick is a bit "looser" than new but it works fine in all directions. I haven't played any games with it and have always been gentle with it, it's rated for 50000 cycles so I doubt it's a malfunctioning joystick.

To me its the time delay back to root which doesn't have sufficient delay.

Comment by Paul Louden (Llorean) - Friday, 27 June 2008, 15:17 GMT
"Latest Revision" means very little. Do you mean latest from when you posted this task, or latest from when you posted the comment? Do you mean daily or SVN current? Please, just post the revision number, that's why I asked for a revision rather than just the yes/no question of "are you using the latest?"
Comment by Joaquim Dias (dunno) - Friday, 27 June 2008, 18:19 GMT
Paul you're obnoxiously pedantic as ever, why couldn't you just have asked, "please state the exact revision number".

the revision that I'm running is r17806
Comment by Paul Louden (Llorean) - Friday, 27 June 2008, 21:46 GMT
Well, with 17812 I don't experience any more sensitivity than Rockbox has ever had in that area. Again, I suspect it's a hardware issue. The delay is the same as it is for any "long" press of a button.
Comment by Joaquim Dias (dunno) - Saturday, 28 June 2008, 08:52 GMT
Looks like I'll have to modify the code myself.

Thanks for looking into it.
Comment by Joaquim Dias (dunno) - Saturday, 28 June 2008, 09:25 GMT
for anyone thats interested in modifying the Left to root action, comment the code as follows

comment out any line that has ACTION_TREE_ROOT_INIT in apps/keymaps/keymap-h1x0_h3x0.c

Thanks to JdGordon for this info.

Loading...