Rockbox

Tasklist

FS#9130 - Fast forwarding during the first second of a song does not work

Attached to Project: Rockbox
Opened by Johannes Voggenthaler (ZincAlloy) - Saturday, 28 June 2008, 21:50 GMT
Last edited by Andree Buschmann (Buschel) - Monday, 15 March 2010, 21:07 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System Iriver H300 series
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Fast forwarding during the first second of a song does not work. Nothing happens on button press. On button release, the song starts from 0.00 again.
This task depends upon

Closed by  Andree Buschmann (Buschel)
Monday, 15 March 2010, 21:07 GMT
Reason for closing:  Works For Me
Additional comments about closing:  Cannot be reproduced anymore.
Comment by Nicolas Pennequin (nicolas_p) - Friday, 04 July 2008, 13:49 GMT
This works for me on an iPod 5.5G. Maybe I'm misunderstanding the issue though. What I did was skip back to the beginning, then seek forward.
Comment by Marc Guay (Marc_Guay) - Friday, 04 July 2008, 16:15 GMT
Sounds to me like you've stumbled across the 'skip to next directory' feature (short-dir+long-dir). If you go to the next track (short) and then try to fast-forward (long), you'll skip to the next directory.
Comment by Johannes Voggenthaler (ZincAlloy) - Saturday, 05 July 2008, 04:55 GMT
I don't think so. it doesn't change directories and I don't use the FF button for selecting the song.
All I do is select a new song and FF as soon as the track starts (while it is still buffering and the playback time isn't updating).
Skipping back and fast forwarding is no problem. The issues start when I select a track that is not buffered yet.
Comment by Nicolas Pennequin (nicolas_p) - Saturday, 05 July 2008, 08:57 GMT
I tried it again as you described it (load the track and FF immediately), and what happened was that there was no sound, as described in  FS#9152 . Pausing and resuming brought the sound back, and it was playing from the right position in the file.
Comment by Johannes Voggenthaler (ZincAlloy) - Sunday, 06 July 2008, 08:52 GMT
no, I'm having the opposite problem: there is sound, although the wps isn't displaying any progress. I just experimented a bit with my settings and it turned out that I'm only experiencing this problem when "gather runtime data" is activated.
Comment by Johannes Linke (Jaykay) - Sunday, 06 December 2009, 16:47 GMT
i can't reproduce any of the problems (ff after starting a song, also with gather runtime data enabled). everything is displayed fine, and i have sound too.

e200 & r23872
Comment by Andree Buschmann (Buschel) - Saturday, 13 March 2010, 08:40 GMT
Imho we should close this entry.
Comment by Johannes Voggenthaler (ZincAlloy) - Monday, 15 March 2010, 19:10 GMT
possibly, I can't reproduce the problem anymore.

Loading...