Rockbox

Tasklist

FS#9148 - Japanese language file

Attached to Project: Rockbox
Opened by Suzuki Takumi (takumiboo) - Thursday, 03 July 2008, 12:40 GMT
Last edited by Jonas Häggqvist (rasher) - Tuesday, 12 August 2008, 17:31 GMT
Task Type Patches
Category Language
Status Closed
Assigned To Jonas Häggqvist (rasher)
Operating System All players
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Sorry, I am Japanese and I can't use English very well.
So I used "Excite translate".

In English:
I noticed there was a place that had still to be translated into the
Japanese language file.
The file is appended.

In Kanji:
私は日本語の言語ファイルにまだ翻訳すべき所があることに気づきました。
ファイルを添付します。
This task depends upon

Closed by  Jonas Häggqvist (rasher)
Tuesday, 12 August 2008, 17:31 GMT
Reason for closing:  Accepted
Additional comments about closing:  Committed in revision 18257. Problems in voice strings should be pointed out/discussed in a new flyspray task.
Comment by Suzuki Takumi (takumiboo) - Thursday, 03 July 2008, 12:53 GMT
In translated English:
I think that there is an improvement in the place in which it has
already been translated.
For example, I think that it is necessary to make "チャネルの設定" to "チャンネルの設定".

How should I do to improve the translation already?
I am not well informed, commit etc. are not understood.

In Kanji:
私はすでに翻訳されたところにも改善点があると思います。
たとえば"チャネルの設定"は"チャンネルの設定"にするべきだと思います。

すでに翻訳されたところを改善するにはどのようにすればいいのですか?
私は詳しくないのでcommitなどは分かりません。
Comment by Taktak (Whick) - Thursday, 17 July 2008, 17:52 GMT
I edited some more voice word.
For exaple, replace the voice of "文字色" with "文字のいろ
voice of "大文字" with "おお文字".
because
"文字色" is read as "もじいろ" by LH Kenji.
"文字しょく" is read as "もじしよく" and
"大文字" is read as "だいもんじ".

And I ajusted all sequence to sort as same as english.lang.


In Kanji:
japanese.langの音声部分をもう少し修正しました。
たとえば「文字色」は、「文字いろ」とし、「大文字」は「おお文字」としました。
理由は、LH Kenjiでは、「文字色」を「もじいろ」と読み、
また、平仮名で「もじしょく」と書いても「しよく」という発音なるので、こうしました。

 さらに「大文字」は「だいもんじ」と発音するので、「おおもじ」と修正しました。

 なお、並び順をenglish.langと同じにしました。
 そうしておかないと、何が足りないのかあるいは、何が廃止されたのかが
 分かりにくいからです。
Comment by Taktak (Whick) - Thursday, 17 July 2008, 18:39 GMT
You need this patch if make japanese.voice with LH-Kenji bundled with office2003.

"LH Naoko" and "LH Kenji" which are Japanese Free SAPI Engines distributed from Microsoft,
But they don't have the Attribute of "Vendor".
So some errors are going to occur in "tools/sapi_voice.vbs" when you make japanese.voice.

I renovated "voice.patch" in  FS#8737  made by MoonWolf.

In Kanji

LH Naoko とLH Kenjiは、マイクロソフトから配布されている、フリーの日本語合成エンジンですが、
Vendorという名の属性を持っていないため、エラーが発生します。
修正するためには、このパッチが必要です。

このパッチは、 FS#8737 で、MoonWolfが作ったを元に改修したものです。
Comment by harry tu (bookshare) - Friday, 25 July 2008, 19:37 GMT
In english:
This file is empty.

In my horrible Japanese:
そのpatchはデイタがありません。
Comment by Taktak (Whick) - Tuesday, 29 July 2008, 15:38 GMT
I'm sorry for being late for replying for you.

I made "sapi_voice_for_lh_kenji_20080718.diff"
to fix voice.pl and sapi_voice.vbs.

But A buggy code in voice.pl has been fixed
since 2008-07-20 as r18102 by Jens Arnold.

I ajusted this patch only for sapi_voice.vbs.
Comment by Taktak (Whick) - Tuesday, 29 July 2008, 15:39 GMT
Sorry, I fogot to attach the file....
Comment by Taktak (Whick) - Tuesday, 29 July 2008, 17:15 GMT
Harru, You're right that "sapi_voice_for_lh_kenji_20080718.diff" is empy.
It might be gotten disconnected before uploading's done.
Please download "sapi_voice_for_lh_kenji_20080730.diff" instead.
Comment by Jonas Häggqvist (rasher) - Tuesday, 29 July 2008, 20:23 GMT
Please do not change voice strings to make them sound better with a specific SAPI voice. This should be done in voice.pl.

Please provide a patch that only fixes problems and adds translations - do not change voice strings.

The SAPI change should be in a separate task.
Comment by Taktak (Whick) - Wednesday, 30 July 2008, 09:02 GMT
I'm sorry. I PROMISE you to effort to provide a patch ONLY to fixes problems and adds translations.
I understand that sapi problem is separate task.

But could you keep in your mind following that if you don't speak and read Japanese,
1. "LH Kenji is bundled with office 2003 and XP. So it's most famouse SAPI engine in Japan.
2. Many new word is made in Japan often.
So I think it's too difficult for most sapi-engines to read kanji word rightly.
For example, When we read 色,we pronouce shiki ,i-ro or shoku depend on word, context and situation.
voice string of japanese.lang file colud be help for it.

By the way, Takumiboo and I had a questionnaire for some tranlation problems problems
in the one of Japanese bulletin board.
(Off cource those problems are "Excluding SAPI problems" )
I'm ready for upload new patch and will upload it after I build and exam it for all-devices.
(using simulators)
Comment by Jonas Häggqvist (rasher) - Wednesday, 30 July 2008, 17:21 GMT
I'm going to have to insist. Do not modify the voice strings to make it sound better. Perhaps someone else is using another voice engine, and then it will not sound correct.

You should modify the file tools/voice.pl to change the string for your voice engine. I can help you with this if you want - but there are examples in there already. Using Rockbox Utility, you can not do this yet, but it will be added eventually.
Comment by Taktak (Whick) - Thursday, 31 July 2008, 12:23 GMT
My expression might be so bad that you might misunderstand my purpose.
The fist purpose of next changing japanese.lang
is NOT to make it sound better but to correct some Japanese traslation.

Off course, I'll put voice-string back to normal absolutely.

> I can help you with this if you want
I am interested in the proposal But I should not ask you voice.pl here, should I?
So I am afraid I can't accept it though I appreciate the concern.
Comment by harry tu (bookshare) - Monday, 04 August 2008, 03:06 GMT
Don't worry. I use VW Misaki and not LH Kenji for I cannot use LH Kenji.

sumimasenn. Watashiwa VW Misaki ga chikaimasu. Watashiwa LH Kenji ga chikaku kotoga dekimasenn.
Comment by harry tu (bookshare) - Monday, 04 August 2008, 04:33 GMT
Japanese.lang's patch needs fixing.

japanese.langのアチはしゅりっしにいいります
Comment by harry tu (bookshare) - Monday, 04 August 2008, 05:32 GMT
I think a better translation for "always" is "itsumo" not "tsunetoki". Just wanted to point that out; if anyone has some objections that's fine.
Comment by Taktak (Whick) - Monday, 04 August 2008, 15:45 GMT
You're wrong what you pronounce "常時"。
We don't pronounce "常時" as "つねとき".
We write "常時" as "じょうじ" in hiragana.

> I think a better translation for "always" is "itsumo" not "tsunetoki".
I think the best translation for always is "常時".
Comment by harry tu (bookshare) - Monday, 04 August 2008, 16:04 GMT
I think a better translation for "always" is "itsumo" not "tsunetoki". Just wanted to point that out; if anyone has some objections that's fine.
Comment by harry tu (bookshare) - Monday, 04 August 2008, 16:06 GMT
Sorry for the double post
Comment by Jonas Häggqvist (rasher) - Monday, 04 August 2008, 16:52 GMT
Harry Tu, do NOT comment on translations for languages you do not speak natively. This is not a request.

Taktak: If you give me an example of a string that needs to be changed to sound better, and tell me the vendor name for the sapi engine - I'll give you a patch for voice.pl and you can extend that as you like.

If you use Rockbox Utility to create voice files, it is not currently possible to do.
Comment by Jonas Häggqvist (rasher) - Monday, 04 August 2008, 17:12 GMT
Based on some discussion in #rockbox, perhaps it would be better to use Hiragana (or katakana?) for voice strings? Would that be better for voice engines? You should still write the words correctly, and we can fix it in voice.pl (and later Rockbox Utility) if it sounds wrong.

None of the involved speaks Japanese, so if this is a bad idea, just ignore us :)
Comment by Jens Arnold (amiconn) - Monday, 04 August 2008, 21:12 GMT
I've committed a workaround for SAPI5 voices with missing vendor attribute. sapi_voice.vbs will now issue a warning, but no error code on exit. As for the changes in UTF8decode(), what are they meant to do? As they are, they cannot work at all. Split(sText, ",", -1) will split the input string at commas, whereas the function needs to work on individual input bytes (auto-converted to wchar by the WSH).

Check whether japanese.lang is in utf-8 format. It has to be in order to work on all platforms.
Comment by Taktak (Whick) - Tuesday, 05 August 2008, 17:10 GMT
I rearranged the order of the japanese.lang as same as english.lang
to compare to english.lang easily.
Please adopt the order if it's against the rule.

I rearranged Japanese translation for following that.
(translation for source word)

"ディレクトリ" for Directory
Those translation were mixed with フォルダ and ディレクトリ

"カタログの参照" for "View Catalog"

"の参照" for "Browse sth"

"*の参照" for "Browse *"

"スキップ単位" for "Skip Length"

"トラック単位" for "Skip Track"

"チャンネル" for "channel" and "channels"

etc.
Comment by Taktak (Whick) - Wednesday, 06 August 2008, 05:06 GMT
Hi, jonas. I appreciate your thoughtful reply.

About voice.pl customization
The problematical SapiEngine "LH Kenji" and "LH Naoko"
is bundled with Microsoft Office 2003 or XP which are localized for Japan
so that I think the vender is Microsoft.
though the original equipment manufacturer is "Lernout & Hauspie", I think.

But I don't know the way of determination of vender of the Sapi
because the sapi engine don't have "vendor" attribute.
("Voice.MatchesAttributes("Vendor") property returns false.)"

----------------------------------------
About writing voice string in Hiragana.
It's difficult.
To use Hiragana (or katakana?) is effective solution
against sapi's wrong reading, You're right.
I think we should use Hiragara(or Katakna) for some voice-strings at least.
But To use Hiragana has possibilities to break the tone accent.
Most Japanese accent is not "strong and weak accent" but "tone accent" unlike most Engilsh accent.
I think that Kanji and amount of vocabulary are necessary to express tone accent correctly.
A word with wrong accent will become another word often in Japanese.

Be that as it may, I'll check those voce-strings more for that sapi
before I let you know problematical voice-strings.
Comment by Taktak (Whick) - Wednesday, 06 August 2008, 05:09 GMT
I'm very sorry that the lang file I uploaded yesterday became empty.
I'll upload it again in day.
Comment by Taktak (Whick) - Wednesday, 06 August 2008, 05:32 GMT
Hi, Jens.
I thank you to give this infomation of this update.
I tried to create japanese.voice yesterday with current sapi_voice.vbs ,voice.pl and LH Kenji bundled with MS Office2003.

I built "japanese.lang" with no error occuring. But it doesn't work well.
My Rockbox doesn't speak anything using this voice

After that, I create another japanese.voice
with the SapiEngine, sapi_voice.vbs I fixed, and voice.pl I fixed.
My Rockbox can speak voice-strings well using this japanese.voice.

I'll report more infomation for this problem briefly here in a day.
Comment by Taktak (Whick) - Wednesday, 06 August 2008, 15:23 GMT
Hi jens,

Vendor attribute might not be the cause of the eror.
There is necessary alternation for voice.pl and sapi_voice.vbs
to create voice-files for multibyte-font-language at least if you help us.

I'll upload not sapivbs.patch but sapi_voice.vbs because its line feed code is CR.



By the way, I think that the following code might be unavailability.
WScript.StdOut.WriteLine "Warning - unknown vendor """ & sVendor _
& """ - using default wave format"
I didn't see the that message while I build japanese.voice.
Instead ,these follwing message appeard with sapi_voice.vbs I altered for multibyte-font-language.

--------------------------------------------------------------------------------
Generating voice clips........... 4 [main] perl 1920 delqueue_list::queue_file: Out of queue slots
339720 [main] perl 1920 delqueue_list::queue_file: Out of queue slots
635045 [main] perl 1920 delqueue_list::queue_file: Out of queue slots
1247996 [main] perl 1920 delqueue_list::queue_file: Out of queue slots
.
.
-- same errors continued. --
--------------------------------------------------------------------------------
I think stdout from sapi_voice will be invisible until following code act
so that the message ("Warning - unknown vendor") isn't available is it?
--------------------------------------------------------------------------------
%ret = (%ret,
"stdin" => *CMD_IN,
"stdout" => *CMD_OUT,
"vendor" => $vendor);
--------------------------------------------------------------------------------
Comment by Taktak (Whick) - Wednesday, 06 August 2008, 16:46 GMT
Takumiboo send me new japanese.lang.
Comment by Jonas Häggqvist (rasher) - Wednesday, 06 August 2008, 16:48 GMT
Can you try uploading your complete japanese.lang file as it is now?

You shouldn't need to do escape the string in voice.pl - voice strings need to be UTF-8, and will be converted by sapi_voice.vbs to the appropraite charset for SAPI. I suspect the character set is changed at some point, but I don't know how, when or where.

+ $escape_string =~ s/(.)/sprintf('%d,', ord($1))/eg;

This is certain to break other languages. I can't imagine why it should be needed for Japanese. There must be an error some other place.
Comment by Jonas Häggqvist (rasher) - Wednesday, 06 August 2008, 17:04 GMT
After some discussion on IRC, things start making sense. I've opened a new task for this problem, so let us move this discussion into  FS#9246  and concentrate on the actual translation here.
Comment by Taktak (Whick) - Wednesday, 06 August 2008, 17:27 GMT
>After some discussion on IRC, thing ...
Sound's good but I'm very sleepy because it's 2:14 AM Japan and
customized sapi_voice.vbs and voice.pl are created by Kenjiro Arai(MoonWolf), see  FS#8737 .
So We had better ask him.

B.T.W. Takumiboo polished up new Japanese.lang and I copared to current english.lang.
Comment by Taktak (Whick) - Wednesday, 06 August 2008, 17:32 GMT
this is a report comparing to english.lang. it's for Japanese people watching this flyspray.
Comment by Jonas Häggqvist (rasher) - Wednesday, 06 August 2008, 17:37 GMT
It seems a lot of eyes have been on this translation. I will commit what you have now, and keep this task open for corrections (as unified diffs (diff -u) in the future, please).

As for the problem with voice strings, we should fix that in  FS#9246 .
Comment by Jonas Häggqvist (rasher) - Wednesday, 06 August 2008, 17:40 GMT
Were the changes to japanese.lang all done by Suzuki Takumi? Otherwise, we need the full name of the other contributors so we can give proper credit.
Comment by Taktak (Whick) - Thursday, 07 August 2008, 02:43 GMT
Hold it ! Somebody send me japanese.lang polishd up.I'll upload it after checking it.
Don't commit it still now.
Comment by Jonas Häggqvist (rasher) - Thursday, 07 August 2008, 07:40 GMT
That's fine, I've not done anything yet. We will need the full name of everyone who has contributed to it as a matter of policy.
Comment by Taktak (Whick) - Monday, 11 August 2008, 15:31 GMT
Please commit this file. I have added two credit in this lang-file.
But I must explain to Japanese watchers why I update month-string from Japanese to English.
Jan, Feb, Mar.. were translated into "1月", "2月", "3月",etc now.

They're not wrong but we insist that month-strings should be written in English
as if japanese.lang is selected.

Because these "月" are more UNNATURAL than keeping it in English IN WPS.

The letter of "日" is necessary for using "月" in date-format.(writen like "8月7日" means 7 Jan) But there isn't the way of using "日" in WPS.

In Playscreen, "8月 10日" is natural (if it can be written).
"10 Aug" is comparatively natural even in Japan. But "8月 10" is quite unnatural.
Besides, most Japanese know simple English like Jan, Feb... and we usually use this English in Japanese Calendar
But most Japanese weren't good at listening English so that I didn't change the voice string of these month's string to English.

We came to the decision from answers to questionnaire in a Japanese Bulletin Board.

Description of update for Japanese users -----
1. ソート順で、Alphabeticalは、名前順と変更
2. ビットマップファイルのコンテキストメニューで[背景をロードしました] を選んだら・・・
  英語では、Backdrop Loaded / Backdrop Failed。
  現行:背景をロードしました/背景のロードに失敗しました
  新 :変更しました/変更に失敗しました

4. タッチパッド感度を選んだら、英語では "High" 。
  日本語では"高"とした。

5. 月は英語だとJan,Feb,/日本語表示だと1月,2月,だが、この表記を英語のままとしたい。
理由は、1,2,3と直すなら、wpsを%?cm<1|2|3|...|12>と修正すればよいし、
 日(にち)という表記が使えないので、wps中で、
 Jan,Febより1月、2月と表示したい場合が、(ほとんど)無い。
  

6. "~します"は、基本的には、名詞で終わるか、体言止めで統一し、助詞を「の」にする。
  例.
  "を削除 → の削除""をロードします→の読込み"、 "に書き出し→の保存(cfgファイル)"

  ただし、体言止めや、助詞を"の"にすると、違和感があったり、
  使い慣れた操作に対して、混乱を生みそうな箇所は、翻訳を変更しない。

  ・"最近のブックマークを読み込む"
    解説:"最近のブックマークの読み込み"とすると、"の"が重なるし、違和感もある。

  ・"音楽をレジュームします"
  ・"ディスクをスキャン中"
  ・"シャッフル時にトラックゲインを使用"
    解説:助詞が2個以上ある文章を、"の"で置き換えたとき違和感
  ・"~を~しました"という過去形の文書。
  ・続いて"はい/いいえ"の選択肢が出る場合。
Comment by Jonas Häggqvist (rasher) - Monday, 11 August 2008, 16:09 GMT
I guess "Portable Audio@2ch" isn't anyone's full name. Please provide the actual name of the contributors. Rockbox does not accept anonymous contributions. If you've asked someone for help, you don't have to add them, but the people who've actually done the translation will have to be listed by full name.
Comment by Taktak (Whick) - Tuesday, 12 August 2008, 17:01 GMT
I update comment lines for credit and something following english.lang revision 18251.
Please commit it.

By the way, Where should I discuss follwing topic.
> Comment by Jonas Häggqvist (rasher) - Tuesday, 29 July 2008, 08:23 GMT-12
> Please do not change voice strings to make them sound better with a specific SAPI voice. This should be done in voice.pl.

Could you reopen  FS#9246  for that? Should I discuss this topic into new flyspray?

Loading...