Rockbox

Tasklist

FS#9168 - Seeking always slows down

Attached to Project: Rockbox
Opened by Steve Bavin (pondlife) - Tuesday, 08 July 2008, 09:53 GMT
Last edited by Steve Bavin (pondlife) - Tuesday, 08 July 2008, 10:11 GMT
Task Type Bugs
Category User Interface
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Since smooth seeking was introduced, fast seeking cannot be maintained across a track.

I've only tested on the H300 simulator, so this might be a sim-only issue.

Recipe:
1) Set FF/RW Min Step to 10s and FF/RW Accel to Very fast
2) Play a track (say 4 mins long)
3) Hold fast forward

It starts nice and fast but slows down as you progress, the opposite of the behaviour I'd expect. It's not possible to seek as fast as on the pre-smooth-seeking code.
This task depends upon

Closed by  Steve Bavin (pondlife)
Tuesday, 08 July 2008, 10:11 GMT
Reason for closing:  Not a Bug
Additional comments about closing:  Ignore, I'll look into this further, and on target.

Loading...