Rockbox

Tasklist

FS#9200 - Scrolling line

Attached to Project: Rockbox
Opened by Christopher Williams (christop) - Wednesday, 16 July 2008, 18:12 GMT
Last edited by Jonathan Gordon (jdgordon) - Thursday, 17 July 2008, 02:50 GMT
Task Type Bugs
Category Applications
Status Closed
Assigned To No-one
Operating System Sansa e200
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

This is at least in r18043 on the Sansa e280. I can't see if this bug has been reported and closed already because Flyspray is acting up and won't let me see closed bugs at the moment, however I doubt it's been fixed because I see no mention of it in the changelog since this revision.

How to reproduce bug:

1) Go to the FM radio so it is the "now playing" application (as opposed to the audio player application).
2) Go to Files or Database and scroll down to a file/song with a long name (long enough that the line has to scroll horizontally to show the full name).
3) Press the "play/pause" button to take you back to the FM radio.

The bug is that the line still scrolls in the FM radio screen. Similarly, if you go to a directory in Files whose full path name at the top of the screen is long enough to scroll horizontally (such as when the full path name is displayed in File View), the path name will still scroll in the FM radio screen. In fact, a scrolling path name and a scrolling file name can both still appear in the FM radio screen at the same time.

There was recently a related bug where the scrolling line(s) still appeared in the "erase dynamic playlist?" confirmation screen when you select a song with a long name, but that appears to be fixed.
This task depends upon

Closed by  Jonathan Gordon (jdgordon)
Thursday, 17 July 2008, 02:50 GMT
Reason for closing:  Accepted
Additional comments about closing:  thanks
Comment by Christopher Williams (christop) - Wednesday, 16 July 2008, 19:27 GMT
I attached a patch to apps/recorder/radio.c that seems to work. It just adds a call to stop_scroll() in the initialization of the radio screen.

Alternatively, I'm wondering if it would be a good idea to call lcd_stop_scroll() from lcd_clear_display() because I would think that if you want to clear the display, you also want the scrolling lines to stop. The same applies to lcd_remote_stop_scroll() and lcd_remote_clear_display().

Side note: I could not find the definition of lcd_remote_clear_display() nor of lcd_remote_clear_viewport() anywhere in the Rockbox source (I ran a "find -exec grep" type of command at the source root), but I found several references to it. Curious.

Loading...