Rockbox

Tasklist

FS#9263 - Cygwin setup fails due to missing setup.ini.sig file.

Attached to Project: Rockbox
Opened by Davide (Davide-NYC) - Monday, 11 August 2008, 12:09 GMT
Last edited by Daniel Stenberg (bagder) - Monday, 29 June 2009, 17:36 GMT
Task Type Bugs
Category Build environment
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

When the Cygwin installer is pointed to http://download.rockbox.org/cygwin/ an error is displayed that says "Unable to get http://download.rockbox.org/cygwin//setup.ini.sig from <http://download.rockbox.org/cygwin/>"

setup.ini.sig does not seem to exist on the download server.
This task depends upon

Closed by  Daniel Stenberg (bagder)
Monday, 29 June 2009, 17:36 GMT
Reason for closing:  Not a Bug
Additional comments about closing:  This is a cygwin issue, but we must simply document setup -X as the workaround to use.
Comment by Anthony Mercuri (cool_walking_) - Wednesday, 13 August 2008, 08:04 GMT
It seems the repository needs to be updated according to this announcement:
http://www.cygwin.com/ml/cygwin-announce/2008-08/msg00001.html
Comment by Tomer Shalev (tomers) - Friday, 29 August 2008, 21:58 GMT
Any news on this one?
Are we going to start signing our custom-generated setup.ini and setup.bz2 files with gpg?

The bypass for this issue is to supply the new -X (--no-verify) command-line flag when using setup.exe to download from Rockbox mirror. This can be added into the command-line invocation in a Windows shortcut, for convenience.
Comment by Tomer Shalev (tomers) - Saturday, 30 August 2008, 09:10 GMT
Added Twiki info on how to bypass this problem. See http://www.rockbox.org/twiki/bin/view/Main/CygwinDevelopment
The issue should still be address, though.
Comment by Linus Nielsen Feltzing (linusnielsen) - Monday, 01 September 2008, 07:06 GMT
I will fix this, but not by self-signing the packages. I will extend the tools/rockboxdev.sh script so it can download and install the compiler binaries from download.rockbox.org instead. Creating the cygwin packages is a pain in the b*tt anyway, so the setup.exe update was just the final nail in the coffin.
Comment by Jonas Häggqvist (rasher) - Thursday, 11 December 2008, 18:11 GMT
Any news on this? Linus?

At any rate, maybe rockboxdev.sh should be the only official way to get the crosscompilers from now on - whether or not there's a package on download.rockbox.org or not and the Cygwin mirror should be taken out of service.

Loading...