Rockbox

Tasklist

FS#9361 - Colour selection screen broken with large font (all colour targets)

Attached to Project: Rockbox
Opened by Jens Arnold (amiconn) - Wednesday, 03 September 2008, 20:47 GMT
Last edited by Peter D'Hoye (petur) - Sunday, 07 September 2008, 20:09 GMT
Task Type Bugs
Category User Interface
Status Closed
Assigned To No-one
Operating System Iriver H300 series
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

The colour selection screen is broken with larger fonts (>= 14 pixels is sufficient for reproducing the bug). The R/G/B to the left of the sliders and the values to the right overlap each other, because the vertical slider spacing isn't adjusted to the font size.

Also, the RGB value shown in the colour example rectangle should probably be printed using the user font, not the sysfont.
This task depends upon

Closed by  Peter D'Hoye (petur)
Sunday, 07 September 2008, 20:09 GMT
Reason for closing:  Fixed
Comment by Peter D'Hoye (petur) - Sunday, 07 September 2008, 12:22 GMT
attached patch fixes this.... comments on the solution?
Comment by Peter D'Hoye (petur) - Sunday, 07 September 2008, 14:11 GMT
better?
Comment by Peter D'Hoye (petur) - Sunday, 07 September 2008, 14:18 GMT
fix a warning
Comment by Peter D'Hoye (petur) - Sunday, 07 September 2008, 14:22 GMT
fix error for certain archos players
Comment by Peter D'Hoye (petur) - Sunday, 07 September 2008, 14:42 GMT
includes remote functions - no longer crashes targets with remotes ;)

Loading...