Rockbox

Tasklist

FS#9400 - tools/configure more improvements

Attached to Project: Rockbox
Opened by Rosso Maltese (asettico) - Sunday, 14 September 2008, 15:00 GMT
Last edited by Thomas Martitz (kugel.) - Sunday, 09 August 2009, 19:03 GMT
Task Type Patches
Category Build environment
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

This patch extends the improvements supplied by #8842 to all the values read from stdin.
The command line options added are:

--atype=ATYPE
--language=LANG
--tts=ENGINE
--ttsopts=OPTS
--encopts=OPTS

ATYPE can be a string containing one or more letters, as showed in advanced build menu.
This task depends upon

Closed by  Thomas Martitz (kugel.)
Sunday, 09 August 2009, 19:03 GMT
Reason for closing:  Accepted
Additional comments about closing:  Committed in r22228. Thanks a lot!
Comment by Rosso Maltese (asettico) - Monday, 23 February 2009, 17:05 GMT
Sync'd against today's daily build (r20089).
Comment by Thomas Martitz (kugel.) - Friday, 12 June 2009, 09:58 GMT
Would it be possible to remove --atype, and fuse it with --type? You can't have both at the same time, so --type could be replaced if "a" is given or something.
Comment by Rosso Maltese (asettico) - Friday, 12 June 2009, 10:08 GMT
I' sync-ed it with current build to fix some line number offsets and fuzz factor. I just have to upload the new file.
I can think to reorganize the added arguments. I'm not sure, but maybe I added the option atype since due to an overload between normal and advanced options, so it's possible to use the same letters as indicated by the output in the intercative execution. But I need to check them.
Stay tuned! :-)
Comment by Thomas Martitz (kugel.) - Friday, 12 June 2009, 10:11 GMT
I'm thinking if --type starts with "a" then it can't be a normal build anymore, so overloading sounds possible to me.
Comment by Rosso Maltese (asettico) - Friday, 12 June 2009, 15:52 GMT
Here it is the updated patch, sync'd against build r21259.
It supports following command line arguments (some of them belong to  FS#8842 ):
--target=TARGET
--ram=RAM
--type=TYPE
--language=LANG
--tts=ENGINE
--voice=VOICE
--ttsopts=OPTS
--encopts=OPTS
--rbdir=DIR
--ccache
--no-ccache
--help

Now --type accepts a string to select multiple options.
So, if I want to build voice, I will do:
../tools/configure --type=av ...

For the bootloader, I will do:
../tools/configure --type=b ...

For the backlight option (when allowed), I will do:
../tools/configure --type=ab ...

(According with my naming rule for the patch files, last number before the extension indicates the value to be used in patch -p. HTH)
Comment by Thomas Martitz (kugel.) - Friday, 12 June 2009, 17:37 GMT
Great, gonna check this out
Comment by Rosso Maltese (asettico) - Saturday, 20 June 2009, 13:13 GMT
Sync'ed against current build (r21388).
Comment by Thomas Martitz (kugel.) - Saturday, 20 June 2009, 14:22 GMT
Seems to work well! I'm all for committing (I think I'll do it soonish).
Comment by Thomas Martitz (kugel.) - Saturday, 20 June 2009, 19:25 GMT
Alright, I have had a look.

Nothing against the patch itself, but we're getting short on args. The current implementation is badly limited to 10 arguments. This will make adapting make reconf quite hard (it passes all arguments at once). Do you have some plans regarding that?

Also, I was having problems with voice builds. Well, I don't have any voice engine installed, but maybe you can take another look at it?
Comment by Rosso Maltese (asettico) - Saturday, 20 June 2009, 20:25 GMT
Actually, I already saw that fancy use of the command line arguments. Maybe a simple "$@" can fix the problem, but I need to investigate.
Probably a clearer way to manage the arguments should be implemented. I will try to rewrite it without change the script logic.
Thanks for the warning.
Comment by Thomas Martitz (kugel.) - Saturday, 20 June 2009, 20:52 GMT
That rewrite should probably done before this patch, what do you say?

It would be awesome if you volunteer for that. It's obvious I fail at this thing :)
Comment by Rosso Maltese (asettico) - Saturday, 20 June 2009, 21:04 GMT
Absolutely yes.
The major problem is that I'm thinking to completely rewrite the script, but I don't know the use of the different compiler options, so a slight mistake on reproducing the same use of them could lead to a big headaches. ;-)
Anyway I will try.
Comment by Thomas Martitz (kugel.) - Saturday, 20 June 2009, 21:15 GMT
Completely rewriting seems a bit exaggerated. Is there any need to?
Comment by Rosso Maltese (asettico) - Saturday, 20 June 2009, 21:33 GMT
Ok, "completely" is really exaggerated. I will concentrate just on the arguments.
Comment by Rosso Maltese (asettico) - Monday, 22 June 2009, 22:58 GMT
Sync'ed against current build (r21475).
No changes introduced yet about command line arguments as discussed earlier.
Comment by Rosso Maltese (asettico) - Tuesday, 23 June 2009, 10:37 GMT
This patch, applied after "build-9400configure-args_v5.0.patch" of the previous comment, normalize the script indentation ( vim: :set shiftwidth=4 tabstop=4 expandtab).
Comment by Thomas Martitz (kugel.) - Sunday, 12 July 2009, 00:56 GMT
Any progress?

PS: We don't want the indentation changes I think.
Comment by Rosso Maltese (asettico) - Tuesday, 14 July 2009, 11:18 GMT
I'm sorry, Thomas, I started working hard again, so my spare time is reduced!
I hope to complete the arguments management soon.
OK, for the indentation, I did it just because I found it a little bit fuzzy! ;-)
Comment by Rosso Maltese (asettico) - Sunday, 02 August 2009, 18:56 GMT
Here it is the "final" patch.
I'm not sure about the use of the options --ccache and --no-ccache, but I think to be maintained the original behaviour.
Note: some options work together (i.e. --type=av --encopts='-c 10 -q 10'). If you want to leave an option value empty, set it to a blank, like --type=av --ttsopts=' '
Comment by Thomas Martitz (kugel.) - Sunday, 02 August 2009, 19:00 GMT
I'll have a look!

Loading...