Rockbox

Tasklist

FS#9405 - deleting an empty folder resultet in deleting everything in the root-folder, rockbox unbootable now

Attached to Project: Rockbox
Opened by Panagiotis Papadopoulos (pano) - Monday, 15 September 2008, 11:26 GMT
Last edited by Nils Wallménius (nls) - Tuesday, 02 December 2008, 12:59 GMT
Task Type Bugs
Category Operating System/Drivers
Status Closed
Assigned To No-one
Operating System Sansa e200
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Yesterday I wanted to create a folder while running rockbox. After naming the folder and saving it, the Virtual Keyboard froze during the creation, so that I had to press and hold down the power-button in order to reboot rockbox. The music was still playing though.

After booting up, I went to the folder, where I created the before mentioned folder and noticed, that everytime I opened that folder, it listed me the content of the / Folder (root).

So I tried to delete the folder and after pressing the button, I noticed that it tried to delete everything in my / folder.
I pressed the powerbutton again so that rockbox would reboot again, but somehow the deletion of the folder, managed to delete my rockbox.mi4 from the .rockbox folder, leaving my rockbox unbootable.
Everytime I tried to bootup Rockbox, i always got the following error-messages:
"Can't load rockbox.mi4" File not found
and
"Can't load rockbox.e200" File not found

pano
This task depends upon

Closed by  Nils Wallménius (nls)
Tuesday, 02 December 2008, 12:59 GMT
Reason for closing:  Not a Bug
Additional comments about closing:  Very likely to be caused by a corrupt filesystem, request a reopen if this can be reproduced.
Comment by Frank Gevaerts (fg) - Wednesday, 17 September 2008, 12:57 GMT
Can you reproduce this on a freshly checked filesystem? (use chkdsk /f or fsck.vfat to check) ?

I strongly suspect that you had a corrupted filesystem
Comment by Panagiotis Papadopoulos (pano) - Wednesday, 17 September 2008, 13:38 GMT
I don't know if I can reproduce this, because I don't really know how I can make the Virual Keyboard freeze, as I think the "main error" must be somewhere there.
But I will try it later and report my results.

Loading...