Rockbox

Tasklist

FS#9444 - Balance setting not working properly

Attached to Project: Rockbox
Opened by Clément Pit--Claudel (CFP) - Thursday, 02 October 2008, 21:14 GMT
Last edited by Steve Gotthardt (gotthardt) - Saturday, 27 December 2008, 21:05 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To Steve Gotthardt (gotthardt)
Operating System All players
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

It seems to me that the 'balance' setting is correlated to volume setting : the louder the music, the more important the volume difference between the earphones. Plus,, when the sound is of, but the balance is not set to 0, the music keeps playing.

Steps to reproduce :
Set the balance to +100%
Turn the to mute

Also
Set the volume to a quite low value, and move from +100 to -100

CFP
This task depends upon

Closed by  Steve Gotthardt (gotthardt)
Saturday, 27 December 2008, 21:05 GMT
Reason for closing:  Fixed
Comment by Dan Everton (safetydan) - Saturday, 04 October 2008, 00:33 GMT
What target/player are you seeing this on?
Comment by Clément Pit--Claudel (CFP) - Saturday, 04 October 2008, 05:47 GMT
On my Gigabeat F, running latest build.
Comment by Clément Pit--Claudel (CFP) - Saturday, 04 October 2008, 05:53 GMT
It seems to me that on the sim the volume cannot go under 72, while on the target it goes down to 73, before being set to mute. Is this normal ?
Comment by Steve Gotthardt (gotthardt) - Saturday, 27 December 2008, 01:22 GMT
I have a Gigabeat FX and I have confirmed this - I'll take a look.
Thanks for reporting it.
S
Comment by Steve Gotthardt (gotthardt) - Saturday, 27 December 2008, 10:07 GMT
I made a couple of minor changes and it seems to work.
I am going to chat on IRC to see if there are any 'gotchas' before submitting.

The problem is in sound.c
When balance is reduced below VOLUME_MIN it is set to VOLUME_MIN. It should be muted.
I removed the checks for this because the volume is clamped in the respective audio device drivers (ie wm8751.c)

S
Comment by Steve Gotthardt (gotthardt) - Saturday, 27 December 2008, 21:05 GMT
I committed the fix. Tested only on Gigabeat F40.
Note: due to crosstalk, etc. program material can be heard on muted channels at high volumes. For example: put balance entirely on right channel, raise volume high and you can hear some sound on the left channel. Could be it is just my player.

Loading...