Rockbox

Tasklist

FS#9445 - Last.fm Log not working and possible Cuesheet bug

Attached to Project: Rockbox
Opened by Nate Rowe (Spanky) - Friday, 03 October 2008, 04:45 GMT
Last edited by Steve Bavin (pondlife) - Friday, 03 October 2008, 21:16 GMT
Task Type Bugs
Category Applications
Status Closed
Assigned To No-one
Operating System iPod 4G Color
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I've been trying to enable the Last.fm log file in the settings and it tells me to reboot, I do and I go back into the settings and it's still disabled. I looked in the config file and it's not even listed in there.

Also, I enabled the Cuesheet Support, restart and it says "no" for not enabled. It says "yes" in the config. When I load a CUE file, it loads the song list and I can scroll through that but that's it. Is that all it does? I was thinking you would be able to select and play a song or something out of it.

Sorry if I double post, my internet is being very weird now.
This task depends upon

Closed by  Steve Bavin (pondlife)
Friday, 03 October 2008, 21:16 GMT
Reason for closing:  Not a Bug
Comment by Nils Wallménius (nls) - Friday, 03 October 2008, 06:35 GMT
You need to make a proper reboot by holding play untill rockbox powers down and then restart, Menu+Select is a hard reset and will not allow rockbox to save settings. I am guessing this is the problem since you don't state how you reboot.
Comment by Nate Rowe (Spanky) - Friday, 03 October 2008, 19:21 GMT
Yea, I wasn't aware of the differences between holding play and menu+select but it makes sense. I should probably shut it down more, usually I either reboot with menu+select or let the player shut itself down. I plugged the iPod into USB while rockbox was running and it rebooted, I'm guessing the settings got saved then because they work now. Is this in the manual/wiki for the Last.fm Log? I don't recall reading this when I looked up how to use it. Thanks for clearing this up Nils. Feel free to close this.

Loading...