Rockbox

Tasklist

FS#9468 - error playing some ogg files

Attached to Project: Rockbox
Opened by Atze Wellblech (tyrone) - Wednesday, 08 October 2008, 13:39 GMT
Last edited by Nils Wallménius (nls) - Wednesday, 08 October 2008, 18:15 GMT
Task Type Bugs
Category Codecs
Status Closed
Assigned To No-one
Operating System Iriver H100 series
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

The rockbox firmware does not play some of my ogg files, but the original iRiver firmware (v1.66EU) does this as well as my notebook (audacious, xine, vlc).
This task depends upon

Closed by  Nils Wallménius (nls)
Wednesday, 08 October 2008, 18:15 GMT
Reason for closing:  Not a Bug
Additional comments about closing:  This file has an ID3 tag at the beginning, this is not legal for ogg/vorbis, thus the file contains an error and rockbox skips it.

If you strip the id3 the file plays just fine.
Comment by Steve Bavin (pondlife) - Wednesday, 08 October 2008, 14:25 GMT
Please attach an example file.
Comment by Atze Wellblech (tyrone) - Wednesday, 08 October 2008, 15:35 GMT
Cannot attach, its too big. You'll find it here:
http://area51.qayx.net/sample.ogg
Comment by Alex Meyer (binaryhermit) - Wednesday, 08 October 2008, 16:20 GMT
Well, it's not the floor 0 bug.
As far as I can tell, the file was encoded by libvorbis 1.1
Also, I can confirm this on a Sansa e260

Loading...