Rockbox

Tasklist

FS#9489 - nonlinear frequency response for all codecs

Attached to Project: Rockbox
Opened by Przemysław Hołubowski (p.h.) - Tuesday, 14 October 2008, 20:35 GMT
Last edited by Peter D'Hoye (petur) - Saturday, 18 October 2008, 21:58 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Recent builds degrade frequency response. It is not flat any longer.

Take a look at my measurements. I have prepared a 10 second long white noise wave, aac and mp3 files and playback it on an old build and a recent one (from 14.10). Results are showing that current build applies some low-pass filtering in a whole audible frequency range and especially in 2-10kHz range.

I think it was introduced a week or more ago.
This task depends upon

Closed by  Peter D'Hoye (petur)
Saturday, 18 October 2008, 21:58 GMT
Reason for closing:  Fixed
Additional comments about closing:  FS #9496 accepted
Comment by Paul Louden (Llorean) - Tuesday, 14 October 2008, 20:40 GMT
Please narrow it down to a specific build, to make it easier for someone to find and fix the problem.
Comment by Nils Wallménius (nls) - Tuesday, 14 October 2008, 21:24 GMT
Also please make sure you don't have any sound aletring settings enabled, like EQ, crossfeed etc. and tell us which player you're using.
Comment by Przemysław Hołubowski (p.h.) - Tuesday, 14 October 2008, 21:41 GMT
I will try. For now I can only add the bug exists for over one month (daily build from the 14th of September has it). I will search older revisions.
Comment by Przemysław Hołubowski (p.h.) - Tuesday, 14 October 2008, 21:42 GMT
I am using H10 20GB. Of course I have all EQ related settings disabled.
Comment by Przemysław Hołubowski (p.h.) - Tuesday, 14 October 2008, 21:47 GMT
I guess it's caused by rev. 18478. I'll check it tomorrow.
Comment by Przemysław Hołubowski (p.h.) - Tuesday, 14 October 2008, 22:32 GMT
Revision 18478 introduced the deemphasis present up to now, but in revision 18476 preemphasis was present (see screenshot).
Comment by Jens Arnold (amiconn) - Tuesday, 14 October 2008, 23:11 GMT
r18478 just fixes a bug that caused the (intended) activation of deemphasis not to work. It was intended to be activated since r14948 (2 Oct 2007!). However, I have no real idea why it should be activated. jhMikeS might know as he added this.

There's a relatively easy way to find out. In firmware/drivers/audio/wm8731.c, remove the "| DAPCTRL_DEEMP_44KHz" part in line 64. Furthermore make the audiohw_set_nsorder() function (line 207ff) an empty function. If this gives linear response, the deemphasis setting is the problem and should be deactivated in SVN as well.
Comment by Przemysław Hołubowski (p.h.) - Wednesday, 15 October 2008, 18:00 GMT
The revision which I initially referred to as an old one is rev. 17523. The revision gives flat frequency response.

Doing the changes you've suggested amiconn results once more in nonlinear frequency response (look at atached screenshot). This time high frequencies are boosted.

I'm investigating changes from revision 18294.
Comment by Przemysław Hołubowski (p.h.) - Thursday, 16 October 2008, 07:49 GMT
The strange thing is that OF gives the same frequency response as on the last screenshot, i.e. with slightly boosted high frequencies (in range 4kHz-18.5kHz). Of course with all EQ, SRS turned off. I have once again measured rev. 15723 which initially gave me flat response and this time it produced the same response as the one visible on the last screenshot.
Moreover, very old build from my small H10 gives the same response too.
I must say I'm a bit confused here.

Loading...