Rockbox

Tasklist

FS#9490 - iPod Disk Space

Attached to Project: Rockbox
Opened by Nate Rowe (Spanky) - Tuesday, 14 October 2008, 22:37 GMT
Last edited by Steve Bavin (pondlife) - Friday, 17 October 2008, 07:54 GMT
Task Type Bugs
Category Applications
Status Closed
Assigned To No-one
Operating System iPod 4G Color
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Around the 3.0 release and ever since then my "Free" space left that is displayed in the Rockbox Info and Debug sections hasn't changed. It's stayed at 446mb even though I have 3gb left or even 10gb left. Doesn't seem to update. I've initialized the database several times since 3.0 and that hasn't affected it. I couldn't pinpoint the exact build where it got like this but I'm pretty sure it was either the 3.0 release or a few builds before.
This task depends upon

Closed by  Steve Bavin (pondlife)
Friday, 17 October 2008, 07:54 GMT
Reason for closing:  Not a Bug
Additional comments about closing:  Just Windows being silly.
Comment by Jonathan Gordon (jdgordon) - Wednesday, 15 October 2008, 09:34 GMT
This is most liekly not a bug in rockbox, but a problem with the filesystem. Run a filesyster checker on it
Comment by Nate Rowe (Spanky) - Wednesday, 15 October 2008, 09:38 GMT
What kinda filesystem checker? This did work fine before, in fact when I forgot how much I had, I used to check it quite frequently.
Comment by Jonathan Gordon (jdgordon) - Wednesday, 15 October 2008, 09:41 GMT
if your on windows look for the check disk option in the drives properties window... mac dunno... linux fsck.vfat
Comment by Nate Rowe (Spanky) - Wednesday, 15 October 2008, 09:44 GMT
I don't really think it's a problem with the disk but I will run a check tomorrow, it will take a long time.
Comment by Linus Nielsen Feltzing (linusnielsen) - Wednesday, 15 October 2008, 10:10 GMT
This is a common and well-known problem with Windows. It doesn't update the FSINFO structure on the disk, where the free space info is located. You can force a recalculation of the free disk space by pressing SELECT in the Rockbox Info screen.
Comment by Nate Rowe (Spanky) - Friday, 17 October 2008, 06:54 GMT
Awesome, pressing select fixes it. I am still disappointed, all my "bugs" seem to be un-related with Rockbox. Thanks, this can be closed now.

Loading...