Rockbox

Tasklist

FS#9550 - Settings are not searchable in xpdf

Attached to Project: Rockbox
Opened by Björn Stenberg (zagor) - Friday, 14 November 2008, 08:11 GMT
Last edited by Dominik Riebeling (bluebrother) - Monday, 01 December 2008, 21:22 GMT
Task Type Bugs
Category Manual
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Sections of the manual marked \setting{} cannot be searched in xpdf.
This task depends upon

Closed by  Dominik Riebeling (bluebrother)
Monday, 01 December 2008, 21:22 GMT
Reason for closing:  Fixed
Additional comments about closing:  caused by the formerly used default font Palatino. Switched to LaTeX defaults.
Comment by Jonathan Gordon (jdgordon) - Friday, 14 November 2008, 08:16 GMT
added  FS#5721  as related although its not really, but if its going to be fixed anyway it should fix both tasks.
Comment by Frank Gevaerts (fg) - Friday, 14 November 2008, 09:51 GMT
Actually, from looking at  FS#5721  I suspect it's exactly the same bug
Comment by Nils Wallménius (nls) - Monday, 24 November 2008, 22:16 GMT
In the pdfs it seems that the words in \setting{} macros are searchable if you exclude the first char in the word, so looking for "Playlist" a search for "laylist" would match. Since we use Title Case for settings the first char of every word is in a different font(size) than the others so this may be a limitation in the pdf format or pdflatex.
If we can't work around this somehow I'd suggest we drop the Title Case, or if we want to keep that, the small caps style for the \setting{} macro and use some other style as searching is imho more important than aesthetics.
Comment by Dominik Riebeling (bluebrother) - Thursday, 27 November 2008, 19:46 GMT
I looked in the soul package for fixing this a couple of days back. The results look quite promising, but currently this breaks on a few places, and I haven't figured out why this happens. Creating small example tex files do work for the cases that break for the manual. Using soul also fixes the html issue and gives the possibility of using a background "marker" color if we find it to be appropriate, thus I'm strongly in favour of figuring why this breaks and fixing that :)
Comment by Dominik Riebeling (bluebrother) - Saturday, 29 November 2008, 08:33 GMT
Interesting finding on this: you *can* search for the small caps strings, *if* you put a space after each capital letter -- "m anage s ettings" finds the "Manage Settings" string. This works regardless if soul is used for small caps or not. When converting the pdf to txt using pdftotext there is clearly a space shown after captial letters. So it seems LaTeX puts a box between those letters.

Loading...