Rockbox

Tasklist

FS#9558 - Next Song Title Wrong after |<< {Back}

Attached to Project: Rockbox
Opened by Al Waschka (Al W) - Monday, 17 November 2008, 05:32 GMT
Last edited by Jonathan Gordon (jdgordon) - Wednesday, 16 December 2009, 06:05 GMT
Task Type Bugs
Category User Interface
Status Closed
Assigned To No-one
Operating System Sansa e200
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

Current Build loaded today, 11/17/08. Sansa E200 2GB. Music files stored on micro-SD. English voice added, but not enabled. WPS screen seems to have an error in reading titles to display for {next song} if |<< (back)is pressed twice. If press |<< to get song to start over, then press |<< to go to previous song in first few seconds of song, next song name is wrong. If >>| is then pressed while song display reading the wrong song name, the correct next song plays, but it is not the song that was listed as next during the previous play. Also after multiple presses of |<<, the display has a transient where song title is displayed, but artist line says "root", album line says "root", and year line is blank.
This task depends upon

Closed by  Jonathan Gordon (jdgordon)
Wednesday, 16 December 2009, 06:05 GMT
Reason for closing:  Out of Date
Additional comments about closing:  feel free to reopen if this is still an issue... I havnt heard any other reports and cant repro it here
Comment by Marc Guay (Marc_Guay) - Monday, 17 November 2008, 12:14 GMT
Are you saying that the WPS is just slow to update the information or that it remains wrong for the duration of the song?
Comment by Al Waschka (Al W) - Monday, 17 November 2008, 15:11 GMT
The title is correct. The "next song" is wrong and remains wrong until you press >>| to go to the next song. The song that plays is the next song on the album but that is not what "next song" is saying should play next. BTW I realized that I had not indicated which THEME I was using, but the two I checked, both had the error.
Comment by Marc Guay (Marc_Guay) - Monday, 17 November 2008, 15:22 GMT
Cannot reproduce with e200 & r18996. This sounds a lot like a playback problems which were fixed a while ago. Can you confirm the revision number (not date) of your build?
Comment by Al Waschka (Al W) - Tuesday, 18 November 2008, 01:12 GMT
OK, I have Rockbox Version R18607-3.0-080923. I loaded it from the "current release" link (actually on 11/16/08, but by the time I wrote the FS entry it was 11/17. I'm new to all this, so I loaded the "current release". I guess I need to update it to get bug fixes, etc. The behavior I observe is not deterministic, and actual displays seem to depend on the theme. I tried several repetitions of the same key presses and got different results. Currently running theme iCatcher. Sometimes next song shows "?" after several presses of {|<<}, sometimes it just shows the wrong song. Sometimes the "?" is transient, i.e. it updates after several seconds to a song name, sometimes not. But I guess the "current release" is not what I should be running?

Thanks
Comment by Marc Guay (Marc_Guay) - Tuesday, 18 November 2008, 02:08 GMT
The current release (v3.0) is a known-state stable release. I've played around a bit to see if I can replicate your issue and notice that if I'm on the last song of an album while using the iCatcher theme, the next song is displayed as a question mark. This is normal behavior. The fact that the <root>'s and ?'s may take a second to update, although not desirable, is also somewhat expected. Can you reproduce any problems outside of these situations?
Comment by Al Waschka (Al W) - Tuesday, 18 November 2008, 14:10 GMT
Actually, in iCatcher, if I scroll down to the last song and start play, the next song starts off as the first song. This would seem to be correct since iCatcher seems to be designed to play songs in a circular mode, that is if I hit >>| while playing the last song, it goes to the first song. If in the last song and I press |<< to restart play and then in the first few seconds press|<< again, it plays the next-to-last song and then shows ? (not monentarily, but stable) as the next song, which should not be correct. I have also seen it get into a state where it is playing, say song 15 and is displaying a song much higher in the list as next song, say song 7. As I said, the behavior is not deterministic, the same key presses from the same starting place do not always yield the same result. This sounds like a timing problem to me but I don't know enough about the operation of the e200 series to speculate on where the problem might be. I should mention that this particular album has a song (#17) which doesn't show up under the single artist's name because it has another artist performing it. So if I come in under the Artist's name and view the album, the song numbers go from 1 to 16, skip 17, and then 18. I just started play on 18 and after a few seconds hit |<< twice. IT skipped to 16 and started play, as it should, but the next song went to ? and stayed there. I hit |<< twice again, and it started playing song 15 (as it should) but now next song is song 7. If I hit >>| it goes back to playing Song 16 (as it should) and next song is now showing 18 (which seems to be corect, since 17 doesn't show up in the list because it has two artists). All the preceding have been while entering through the artist name. I went back into the database and went in through the album to see if it made a difference since song 17 would show up in the list. Starting on song 18, two presses of |<< gets it playing song 16 (I may have hit the buttons before it started playing) but next song is listed as #6. So its not the missing song causing the problem. I tried it again and let song 18 play a little longer. Two presses starts 17 playing but next song shows as #6. This stuff is pretty predictable. All I am doing is pressing |<< to go to the beginning of the song and pressing ||< again within about a half second.
Comment by Al Waschka (Al W) - Tuesday, 18 November 2008, 14:17 GMT
More: If, while in the situation above playing 17 and showing 6 as next, I hit |<< twice, playing goes to 15 and next song stays at #6, doing it again produces the same result, i.e. playing changes but next doesn't. I I let the song play a while and do it again, they both update, i.e.now playing #14 and showing #5 as next song. This is also repeatable, i.e. if I press|<< in the first few seconds of the song, next doesn't update, but if I do it after a minute or so, it does update. Later tonight I'll boot into original FW and see if the problem is still there. That would seem to rule out any hardware problems.

Comment by Al Waschka (Al W) - Wednesday, 19 November 2008, 04:25 GMT
I booted the original FW, but I forgot that it does not display the next song. So there is no way to test for this problem in the original FW. The symptoms look like Rockbox has two separate counters for current_song and next_song and they are getting out of sync. If next_song was calculated as (current_song +1) then this anomaly would not be possible. I'm guessing that for a few seconds or so after each |<< button press Rockbox is calculating/updating and pressing the |<< button during this period is causing errors. If the |<< button was "bouncing" it should be affecting current_song as well as next_song, and it is not.
Comment by Marc Guay (Marc_Guay) - Saturday, 22 November 2008, 19:45 GMT
Please make a backup of your current config and reset the settings to the defaults by holding the record button during the bootup sequence. If the problem persists this could be related to the fact that the songs are stored on the microSD card. I could not reproduce with v3.0 on Sansa e200 and do not have a microSD card to check with.
Comment by Christoph Reiter (lazka) - Monday, 24 November 2008, 14:14 GMT
i had the same  bug 2  days ago.
Sansa e200v1, no sdcard.

fresh install.. (5 minutes old), did some theme settings and switched off the button light.
file view. switched to a folder. choose the first song and did some song skipping.. and a few back.. don't remember.
After that I switched on folder up...into another new folder selected the first.

song played fine but the next song info still showed songs from the folder before. switching to the next song worked but the "next song" info jumped to the next song in the old folder (I'm not 100% sure about that.. might have been the same again..). Going back to the fileview and selecting the first song fixed it.

...as far as i can remember. hope that helps.
Comment by Christoph Reiter (lazka) - Sunday, 14 December 2008, 17:26 GMT
way to reproduce:

- Play a song.
- Change folder and start another song.
- During loading of the new one (before it starts playing) press fast-forward..
- Next song info doesn't get updated
Comment by Marc Guay (Marc_Guay) - Sunday, 14 December 2008, 20:03 GMT
lazka: Does  FS#9629  sound closer to your problem?
Comment by Christoph Reiter (lazka) - Sunday, 14 December 2008, 20:22 GMT
Marc Guay: thanks. Still not the same, but could be the same bug/problem.

Loading...