Rockbox

Tasklist

FS#9574 - Bug in filesorting track number wise

Attached to Project: Rockbox
Opened by Alex Borisov (masayume) - Monday, 24 November 2008, 16:50 GMT
Last edited by Paul Louden (Llorean) - Monday, 24 November 2008, 19:22 GMT
Task Type Bugs
Category Operating System/Drivers
Status Closed
Assigned To No-one
Operating System Iriver H300 series
Severity Low
Priority Normal
Reported Version Release 3.0
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

(As of svn r19197 and has been present since i can remember).

There's a bug in the way that rockbox sorts files that start with track numbers. If i have tracks 1-13 it will list files:

1
10
11
12
13
2
3
4
5
6
7
8
9

Which is obviously annoying. A work around is to append a zero to all values < 10. Could someone please patch the file sort algorithm to fix this? Cheers.
This task depends upon

Closed by  Paul Louden (Llorean)
Monday, 24 November 2008, 19:22 GMT
Reason for closing:  Not a Bug
Additional comments about closing:  Rockbox sorts strictly by the filename string without any logic. In that sense, the files are absolutely sorted "properly" and it's your responsibility to name them properly.

Loading...