Rockbox

Tasklist

FS#9600 - Status bar "stuck" on screen and line selector not updated after theme swtich

Attached to Project: Rockbox
Opened by Dave (dberg918) - Tuesday, 02 December 2008, 01:55 GMT
Last edited by Jonathan Gordon (jdgordon) - Wednesday, 03 December 2008, 09:27 GMT
Task Type Bugs
Category Settings
Status Closed
Assigned To Jonathan Gordon (jdgordon)
Operating System All players
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Next release
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I have been working on a new theme for my Gigabeat F40 and I've noticed an issue with the status bar and line selector. When I switch from the default cabbiev2 theme, which has the status bar enabled, to my new theme, which does not, the status bar is stuck on the top of the screen, and the line selector gradient colors and text color does not update. However, if you back out to the root menu, the settings finally kick in and the status bar disappears and the line selector colors change.

I can confirm that this bug exists in the current build, and as far back as r19220 (this is as far back as I've gone so far, since I was searching for the source of #9599).
This task depends upon

Closed by  Jonathan Gordon (jdgordon)
Wednesday, 03 December 2008, 09:27 GMT
Reason for closing:  Fixed
Comment by Thomas Martitz (kugel.) - Tuesday, 02 December 2008, 09:24 GMT
I might add, that changing the statusbar in the display options doesn't instantly toggle the statusbar anymore.
Comment by Thomas Martitz (kugel.) - Tuesday, 02 December 2008, 10:00 GMT
The bug was introduced in r18933.

Loading...