Rockbox

Tasklist

FS#9604 - Player power button does not behave properly

Attached to Project: Rockbox
Opened by Jacob Rau (JBotAlan) - Thursday, 04 December 2008, 01:47 GMT
Last edited by Jonathan Gordon (jdgordon) - Thursday, 04 December 2008, 06:38 GMT
Task Type Bugs
Category User Interface
Status Closed
Assigned To No-one
Operating System Sansa e200
Severity Low
Priority Normal
Reported Version Release 3.0
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

On my e280, the player is very hard to turn off; I have experienced this with the iPod nano also on a stable scroll wheel.

There are two components to this problem. The first, and probably simplest to fix, is that the delay required to cause a power down is far too long (about 2 seconds, by my quick estimation). If the user wants to use the power button to go back, as it is mapped, they should use a short press (under a half a second; tapping the button will yield a press much shorter than that) and if they want a power-off, they should use something about half a second long, in my opinion. The original firmware, by my stopwatch, powers off after holding the power button for 0.9 seconds, and Rockbox responds after 1.74 seconds. That is, in my opinion, a pretty major rift, and unnecessary as the OF, which uses the exact same mapping, does not pose any problems with accidentally generating a long press when trying to back out of menus.

The second component is that while the user is holding down the power button to initiate a shut-down, the shut-down is aborted if the user bumps any other button or the wheel. This is a fairly common event for me and two other users (Andrew Bennett (http://www.rockbox.org/mail/archive/rockbox-archive-2008-12/0063.shtml), and "Purple Dynasty" (http://www.rockbox.org/mail/archive/rockbox-archive-2008-12/0016.shtml)), and I believe there are others who have not spoken up yet.

I propose that the delay be shortened, and possibly make the other buttons not interrupt the shutdown.

Another direction to go with this could be to stop the music immediately with a press to the power button, and then if the user continues to hold the button, the player should shut down. Then, the idle power-off could take over if a shutdown is not achieved.
This task depends upon

Closed by  Jonathan Gordon (jdgordon)
Thursday, 04 December 2008, 06:38 GMT
Reason for closing:  Not a Bug
Additional comments about closing:  explanation in the comments
Comment by Paul Louden (Llorean) - Thursday, 04 December 2008, 02:09 GMT
The first is unlikely to be fixed. Many users have a hard time pressing buttons for very short periods (less than 1 second). 2 seconds is not a "long" period of time, and 1 second every now and then is not so great a price to pay so that some users can use it effectively period.

Any press and release of the power button should already stop the music. If it doesn't this is a separate bug, as the power button IS mapped as the stop button.

As to "ignoring buttons if other buttons are pressed" this may be something that needs addressed, yes.
Comment by Jonathan Gordon (jdgordon) - Thursday, 04 December 2008, 04:37 GMT
The ignoring other buttons while off is down is not workable.... The power button is used as a key modifier (i.e holding it and pressing left or right in the WPS changes directories or sets the ab mode points), if the other buttons are ignored the best case is that doesnt work anymore... the worst case is the player turns off when you obviously don't want it to.
Comment by Paul Louden (Llorean) - Thursday, 04 December 2008, 04:39 GMT
Alright, so it sounds like a simple case of "Rockbox does more than the original firmware, and that means it has to work differently in some cases."

"Differently" in this respect means assuming people mean to press down any extra buttons that are pressed.

Loading...