Rockbox

Tasklist

FS#9629 - Next song info not displayed after song skipping

Attached to Project: Rockbox
Opened by Marc Guay (Marc_Guay) - Saturday, 13 December 2008, 00:06 GMT
Last edited by Marc Guay (Marc_Guay) - Saturday, 03 January 2009, 14:30 GMT
Task Type Bugs
Category Themes
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Release 3.0
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

e200 & r19361

The next song info is not displayed after skipping songs, and will only update after stopping and restarting the playlist.

Recipe:
1) Select the first song in a directory
2) Skip ahead slowly but surely
3) When you find a song where the next song info does not show up within a reasonable amount of time, stop skipping and observe.

This task depends upon

Closed by  Marc Guay (Marc_Guay)
Saturday, 03 January 2009, 14:30 GMT
Reason for closing:  Works For Me
Additional comments about closing:  Appears to have been fixed.
Comment by Thomas Martitz (kugel.) - Saturday, 13 December 2008, 16:35 GMT
I could not reproduce with my e200. I tried in filebrowser and database. After skipping 30 or so songs (each skipping after about 1s), and the song info was fine each time.
Comment by Marc Guay (Marc_Guay) - Sunday, 14 December 2008, 19:59 GMT
What revision are you using? I can reproduce it consistently with r19411 using both Unicatcher and Cabbie v2.0.
Comment by Jonas Häggqvist (rasher) - Sunday, 14 December 2008, 20:10 GMT
I can certainly see this easily. I don't even have to skip more than a couple of songs. Using the filetree with both shuffle and repeat off.

This is on an e200 using a custom theme and r19431.

Note - this the next song info, not current song.
Comment by Christoph Reiter (lazka) - Sunday, 14 December 2008, 20:20 GMT
I have a similar problem:

It's always reproducible on my e200v1.

(everything in filesystem view)
- Play a song.
- Change folder and start another song.
- During loading of the new one (before it starts playing) press fast-forward..
- Next song info doesn't get updated (shows the 'old' next song from the old folder)

Loading...