Rockbox

Tasklist

FS#9732 - rbutil doesnt report correct version numbers in the info tab

Attached to Project: Rockbox
Opened by Gareth (Mystic_kitsune) - Wednesday, 31 December 2008, 04:58 GMT
Last edited by Dominik Riebeling (bluebrother) - Tuesday, 06 January 2009, 10:48 GMT
Task Type Bugs
Category Rbutil
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

RBUtil reports wrong/mixed version numbers, in the info tab, some numbers are old, some dont even correlate to installed components, and bootloader is given as an md5 checksum hash, ive uploaded a pic of the important segmet, the rest of the themes are the same, seeing as i cant update them....
   ss5.png (143.4 KiB)
This task depends upon

Closed by  Dominik Riebeling (bluebrother)
Tuesday, 06 January 2009, 10:48 GMT
Reason for closing:  Not a Bug
Additional comments about closing:  we use timestamps instead of version numbers in a lot of places to ease numbering. Rockbox Utility 1.0.8 changes this for the bootloader too. Version numbers are arbitrary anyway.

Besides I have no idea what "old numbers" should be.
Comment by Dominik Wenger (Domonoky) - Saturday, 03 January 2009, 18:47 GMT
Why do think that those version numbers are wrong ?

This screen just lists all parts rbutil can detect / finds in the install.log.
For some parts there are no versions numbers, so we store the date. Or for the Bootloader the md5sum.

I dont really see whats the Bug whith this.

Loading...