Rockbox

Tasklist

FS#9793 - USB Connection to FreeBSD machine causes FreeBSD machine to freeze

Attached to Project: Rockbox
Opened by brian connor (bconnor) - Tuesday, 13 January 2009, 05:59 GMT
Last edited by Frank Gevaerts (fg) - Thursday, 17 December 2009, 22:00 GMT
Task Type Bugs
Category Operating System/Drivers
Status Closed
Assigned To No-one
Operating System iPod 5G
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Rockbox version: daily build (current jan 12th 2009), clean config
Ipod version: 5.5G

Connecting rockboxed 5.5G ipod on FreeBSD (tested on 7.0 and 7.1) caused FreeBSD machine to freeze completely, requiring full reboot. It has been this way for many months. It is 100% reproducible.

NOTE: Booting into original ipod firmware and connecting does NOT cause machine to freeze, only using rockbox does. Rebooting into ipod firmware is only way to connect without locking up PC.

More info? Let me know.

Please excuse english.
This task depends upon

Closed by  Frank Gevaerts (fg)
Thursday, 17 December 2009, 22:00 GMT
Reason for closing:  Out of Date
Additional comments about closing:  There have been a lot of USB changes since that time (including switching to our own stack in the current builds). Please submit a new report if this happens again
Comment by Michael Sevakis (MikeS) - Friday, 13 February 2009, 01:35 GMT
Still an issue?

Loading...