Rockbox

Tasklist

FS#9831 - Broken USB detection on the iPod mini2g, Sansa E200v1, and Sansa C200v1

Attached to Project: Rockbox
Opened by Alex Meyer (binaryhermit) - Monday, 26 January 2009, 03:13 GMT
Last edited by Michael Sevakis (MikeS) - Friday, 30 January 2009, 02:40 GMT
Task Type Bugs
Category Operating System/Drivers
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

When I connect my E200, C200, and mini2g running post-r19819 builds into my Linux box, they don't detect that USB is connected, just that the charger is connected.
I've been able to make my Sansas connect to a XP SP3 box.
However, my iPod won't connect with the XP box.
Confirmed to work in r19818 and not work in r19819 on the 2nd generation iPod mini
This task depends upon

Closed by  Michael Sevakis (MikeS)
Friday, 30 January 2009, 02:40 GMT
Reason for closing:  Fixed
Additional comments about closing:  USB connection issues on PortalPlayer targets appear resolved.
Comment by michael (mike_montreal) - Monday, 26 January 2009, 15:42 GMT
I can confirm also that somewhere between r19819 thru r19826 to present, usb connection does not put ipod 60/80 in disk mode.
Comment by SadurnĂ­ (sadur) - Monday, 26 January 2009, 17:40 GMT
I've tried to go back to version 3.1 and it works. In r19859-090126 does not work.
dmesg shows "hub 4-0:1.0: unable to enumerate USB device on port <n>" and nothing more.
Comment by Michael Sevakis (MikeS) - Monday, 26 January 2009, 20:39 GMT
Is anyone here trying to use the USB stack instead of rebooting? I suspect the iPod difficulties might be a separate issue if XP won't respond. I know I can connect anything I have on an XP box (H10, H105GB, e200, Gigabeat S) for with or without rockbox USB enabled.
Comment by Thomas Martitz (kugel.) - Monday, 26 January 2009, 23:13 GMT
I can confirm this with my Sansa e200. I'm having problems connecting to my linux box using the OF as well as Rockbox (with USE_ROCKBOX_USB defined).

Sometimes, after some 10-15 tries, the sanas eventually connects.
Comment by Alex Meyer (binaryhermit) - Monday, 26 January 2009, 23:19 GMT
I've tried both with and without the usb stack on the ipod, and there's no difference, at least on Linux.
Comment by SadurnĂ­ (sadur) - Tuesday, 27 January 2009, 06:48 GMT
In windows also doesn't work. If I switch to original firmware it works correctly in Ubuntu 8.10 and Windows XP SP2 in my machine. With newest rockbox builds does not work in either.
Comment by Ryan (crescentfresh) - Wednesday, 28 January 2009, 20:19 GMT
I am experiencing the same issue on my 60 gig ipod photo. I have narrowed it down that the first daily build this occurs on for this model is 1-23-09, Rev. 19822.
Comment by David Bennett (first500) - Wednesday, 28 January 2009, 20:51 GMT
And I have the same issue on my Ipod Nano, after upgrading from v3.1 to r19869 (2009-01-28) (But Rockbox otherwise ran fine)

I rebooted into Apple firmware and USB detection came back, so I then reloaded v3.1. However on connecting with Rockbox running, I receive error message "Data Abort at 00009C9C"

Unhooking and plugging back in seems to clear it, until the next time. Meanwhile, Rockbox otherwise is running fine.
Comment by Thomas Martitz (kugel.) - Wednesday, 28 January 2009, 20:53 GMT
My problems were related to the cable.

I've applied the patch at  FS#8663  ( sd_write_sectors.diff ) and I do not have any problems at all. Connecting in Rockbox works as fine as in the OF (sansa e200 here).
Comment by Boris Gjenero (dreamlayers) - Wednesday, 28 January 2009, 22:24 GMT
This also sometimes happens on my 5G 30GB iPod with r19870. It seems like it worked if I tried it right after bootup, and it failed if I did other stuff before connecting, but I'm not sure of this pattern.
Comment by Michael Sevakis (MikeS) - Thursday, 29 January 2009, 00:26 GMT
I'm checking an iPod Video 30GB right now. I confimed it doesn't reboot. Strange thing is that even with an older build that I left on it when I borrowed it, reboot on USB connect didn't work either. It didn't take any action.
Comment by Michael Sevakis (MikeS) - Thursday, 29 January 2009, 01:32 GMT
Ok, try r19874 or later. With XP, iPod Video and the Sansas seem to all be happy for me. I'm not sure if it will cure anything for the Linux troubles but who knows. We'll work from there if not.
Comment by Justin Hannigan (Chronon) - Thursday, 29 January 2009, 01:44 GMT
I just tried r19874 on my e200 and it reboots fine into the SanDisk firmware upon insertion of USB.
Comment by Justin Hannigan (Chronon) - Thursday, 29 January 2009, 01:48 GMT
XP SP3 here, by the way.
Comment by Alex Meyer (binaryhermit) - Thursday, 29 January 2009, 03:06 GMT
Reboots into the OF when plugged into a Linux box on the official r19874 build for the mini2g.
Comment by Benjamin Lebsanft (Benjamin_L) - Thursday, 29 January 2009, 08:31 GMT
My Sansa E260 reboots into the OF on my Ubuntu box too when connected to the docking station.
Comment by Michael Sevakis (MikeS) - Thursday, 29 January 2009, 08:54 GMT
Benjamin, that's good right? Not if it's a charger-only plug into the docking station? That part should be long fixed and I tested that by masking the USB data lines with tape before comitting changes.
Comment by Benjamin Lebsanft (Benjamin_L) - Thursday, 29 January 2009, 08:59 GMT
Michael, if I remove the usb plug from the docking station, it's the official sandisk one, and plugging the E260 in afterwards, I get the small charging icon when using the cabbiev2 theme.

I don't know if there was a bug as the latest rockbox version I used was way before r19819. All I know is that r19877 reboots fine when usb is plugged in.
Comment by Christoph (realitysucks) - Thursday, 29 January 2009, 17:10 GMT
I just wanted to state (since my post on the forums didn't receive any answers) that r19874 or later didn't fix this USB detection problem for my iPod Video 80GB G5.5 .
I'm using Windows XP SP3. When I connect the data cable to my iPod, nothing happens, not even charging. Went back to 3.1 now and everything works fine again.
Comment by Ryan (crescentfresh) - Thursday, 29 January 2009, 17:19 GMT
The issue appears to be resolved on today's daily build for the ipod photo (r19878). Thanks for the work to the developers who looked into this for us.
Comment by SadurnĂ­ (sadur) - Thursday, 29 January 2009, 19:07 GMT
Great! it's solved with the build r19879-090129. My iPod 80GB now reboots in disk mode when I plug the USB cable.
Thanks!
Comment by Luis Guzman (Ark74) - Thursday, 29 January 2009, 19:20 GMT
Confirmed to work on iPod 30 GB, under GNU/Linux Ubuntu 8.10. Build r19879-090129. Thanks guys!
Comment by Luis Guzman (Ark74) - Thursday, 29 January 2009, 19:22 GMT
Confirmed to work on iPod 30 GB, under GNU/Linux Ubuntu 8.10. Build r19879-090129. Thanks guys!
Comment by Boris Gjenero (dreamlayers) - Thursday, 29 January 2009, 19:25 GMT
Also works for me. 5G 30GB iPod, Vista SP1
Comment by Christoph (realitysucks) - Thursday, 29 January 2009, 19:32 GMT
Upps... Confirmed that build r19879-090129 solved the USB detection problem for my iPod Video 80GB G5.5 too! (I installed the wrong build before, sorry! Ignore my previous post!) Confusing that the zip file of every daily build is named "rockbox.zip" without the build numer! ;D
Comment by Michael Sevakis (MikeS) - Thursday, 29 January 2009, 19:37 GMT
Christoph, haha! Had me going for a minute! I'll let this go a little bit longer before closing in case anyone has anything to add.

Loading...