Rockbox

Tasklist

FS#9833 - WinPod misdetected as MacPod in rbutilqt

Attached to Project: Rockbox
Opened by Ian Delahorne (ian) - Monday, 26 January 2009, 12:22 GMT
Last edited by Dominik Riebeling (bluebrother) - Sunday, 22 November 2009, 16:39 GMT
Task Type Bugs
Category Rbutil
Status Closed
Assigned To No-one
Operating System iPod 5G
Severity Low
Priority Normal
Reported Version Version 3.1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Tried to install RockBox 3.1 on my iPod 5G with the OSX RButilQT utility v1.0.9. My iPod was incorrectly detected as a MacPod, despite both iTunes, fdisk and ipodpatcher (???) agreeing on it being a winpod with the partition table signature 0xAA55. I've attached the partition table (built from dd if=/dev/disk8 of=iller.bin bs=512 count=1).

Managed to install with ipodpatcher manually, but this bug made the first-time user experience very frustrating.
This task depends upon

Closed by  Dominik Riebeling (bluebrother)
Sunday, 22 November 2009, 16:39 GMT
Reason for closing:  Fixed
Additional comments about closing:  fixed with r23707. Note that waiting for the system to remount the player is still not missing, causing issues in automatic install (see  FS#10100 ).
Comment by Dominik Riebeling (bluebrother) - Monday, 26 January 2009, 19:36 GMT
Rockbox Utility uses *exactly* the same code as ipodpatcher, and relies on ipodpatcher for detection, thus also macpod detection. Please elaborate in detail what you did -- especially your claim of "ipodpatcher (???)" is surprising -- why (???)? Also, did you unplug and reattach the ipod after converting, and did you this before running Rockbox Utility or before running ipodpatcher?
Comment by Björn Stenberg (zagor) - Tuesday, 27 January 2009, 07:30 GMT Comment by Dominik Riebeling (bluebrother) - Friday, 13 March 2009, 20:57 GMT
Looks like this is a generic mac issue -- this thread http://forums.rockbox.org/index.php?topic=20957 looks like the same issue.
Comment by Dominik Riebeling (bluebrother) - Saturday, 14 March 2009, 13:21 GMT
The results posted in the forums here http://forums.rockbox.org/index.php?topic=20957.msg146737#msg146737 make me believe that this is a bug introduced with the bootloader rework that was done after 1.0.7.
Comment by Aaron Blumenthal (ajblumenthal) - Sunday, 09 August 2009, 20:52 GMT
Also encountered this bug, using OSX RButilQT 1.2.2. Autodetect was never successful, nor was RButilQT bootloader installation(error: "could not open ipod"). After reformatting to FAT32 using mkfs.vfat, manual bootloader installation was successful using ipodpatcher 3.0 with 3.0 bootloader, but encountered  FS#9568  when trying to boot rockbox.

Reformatting FAT32 using windows and itunes restore still did not allow autodetect, and still resulted in this bug, but manual installation was successful.

Loading...