Rockbox

Tasklist

FS#9854 - Playback is borked after attempting (and failing) to play a certain file.

Attached to Project: Rockbox
Opened by Anthony Mercuri (cool_walking_) - Saturday, 31 January 2009, 07:46 GMT
Last edited by Andree Buschmann (Buschel) - Saturday, 15 January 2011, 23:34 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I've reproduced this on r19773 on a Gigabeat S and r19888 on an iPod Video sim.

1. Play any file.
2. While it's still playing or paused, play one of these two files:
http://dl.getdropbox.com/u/84704/01%20Thumb.mp3 (6.6MiB)
http://dl.getdropbox.com/u/84704/02%20Green%20Machine.mp3 (5.1MiB)
3. The file fails to play, and attempts to play any other file result in the timer staying still at 0:00. Fast Forward, Rewind, Next, and Previous appear to work (all of the WPS except for "track number" is updated), but playback is still "stuck".
4. Going into MpegPlayer (you don't have to even play the video, getting to the menu is enough) or listening to the radio fixes it.


The rest of the files in the album act normally and play fine. Here's one of them:
http://dl.getdropbox.com/u/84704/14%20Yeah.mp3 (75KiB)

It's not my rip so I'm not sure what encoder/settings were used.
This task depends upon

Closed by  Andree Buschmann (Buschel)
Saturday, 15 January 2011, 23:34 GMT
Reason for closing:  Duplicate
Additional comments about closing:  This is a duplicate to  FS#10930  which describes the underlying failure in more detail.
Comment by Anthony Mercuri (cool_walking_) - Saturday, 31 January 2009, 07:48 GMT
Forgot to mention that both the problem files play fine in mplayer.
Comment by Nils Wallménius (nls) - Saturday, 31 January 2009, 10:36 GMT
I can reproduce this on a h300 sim (no suprise really) simply stopping playback is what's
"fixing" it and that is what radio and mpegplayer does but just pressing stop works as well.
This bug seems to have two parts:
1. For some reason rockbox rejects the file.
2. Trying to play a file that gets rejected while something is playing messes up playback, i tried
with some other files that get rejected and they show the same behaviour.
Comment by Anthony Mercuri (cool_walking_) - Monday, 02 February 2009, 10:01 GMT
On further investigation, I think the two problem files have come from a different rip than the rest of the album*, as the rest of the files have embedded album art and a large comment tag, which those 2 are lacking. Also rather telling is that EasyTAG shows the 2 problem files as having bitrates of "~-2147483648 kb/s", whereas the others have the decidedly more sane 128kbps. mp3info just says they're ~192 VBR though.

*Actually, track 12 seems to have come from yet another rip.
Comment by Magnus Holmgren (learman) - Saturday, 14 February 2009, 17:20 GMT
Rockbox finds a Xing VBR frame where the frame count is zero. This makes Rockbox unable to calculate how long the file is (in time), and the files are considered to have invalid metadata because of this (see audio_finish_load_track in playback.c). So running a VBR-fixer on the files should allow them to play, though Rockbox should handle this case better (it is supposed to just load the next track, ignoring the bad one).

Loading...