Rockbox

Tasklist

FS#9877 - Can't quit the lamp plugin

Attached to Project: Rockbox
Opened by Alexander Levin (fml2) - Saturday, 07 February 2009, 15:31 GMT
Last edited by Jonathan Gordon (jdgordon) - Friday, 13 February 2009, 00:17 GMT
Task Type Bugs
Category Plugins
Status Closed
Assigned To No-one
Operating System Sansa e200
Severity Low
Priority Normal
Reported Version Version 3.1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

r19933: the lamp plugin can only be left via shutdown (long press of POWER), at least on my Sansa e200. All other buttons are ignored.

BTW: there is the patch FS#8934 that implements switching the lamp on and off. Why isn't it committed?
This task depends upon

Closed by  Jonathan Gordon (jdgordon)
Friday, 13 February 2009, 00:17 GMT
Reason for closing:  Fixed
Additional comments about closing:  shold be fixed in r19992.
Comment by Paul Louden (Llorean) - Saturday, 07 February 2009, 15:56 GMT
What button is supposed to exit Lamp on the e200?

Also, please don't use flyspray as a method of asking "why isn't X committed?" If you feel a patch should be committed, send an email to the -dev mailing list with the patch, and stating your willingness to do the work necessary to fix up whatever objections the developers have. "Patch X isn't committed yet" is not a bug, and does not belong here even as a footnote.
Comment by Tri Nguyen (tri170391) - Saturday, 07 February 2009, 16:28 GMT
According to this: http://download.rockbox.org/manual/rockbox-sansae200/rockbox-buildch11.html#x14-25700011.4.8
It's the power button. I can confirm this too.
Comment by Johannes Linke (Jaykay) - Monday, 09 February 2009, 18:16 GMT
introduced in r19925: Fix a wrong check in lamp, spotted by DerPapst

maybe the check is now wrong :)
Comment by Alexander Levin (fml2) - Wednesday, 11 February 2009, 15:36 GMT
I think the comment by tri170391 about the quit button is not correct. Any key not assigned a special function should quit the plugin.
Comment by Tri Nguyen (tri170391) - Thursday, 12 February 2009, 05:03 GMT
It's what said in the manual, but you are right it's any button other than select will do the job.
Comment by Gareth (Mystic_kitsune) - Thursday, 12 February 2009, 12:43 GMT
i can confirm, and i have 2 observations; 1) not all the buttons are ignored, both the left/right keys and the scroll wheel still work, as well as the lock still responds, and 2) the menu is shown a split second, along with the "Shutting down..." dialog, for a fraction of that. beyond that, im kinda baffled.

Loading...