Rockbox

Tasklist

FS#9912 - keyclick doesn't work when playback is paused

Attached to Project: Rockbox
Opened by Andrew Tonner (rakslice) - Monday, 16 February 2009, 08:04 GMT
Last edited by Michael Sevakis (MikeS) - Thursday, 30 June 2011, 07:23 GMT
Task Type Bugs
Category User Interface
Status Closed
Assigned To No-one
Operating System iPod 5G
Severity Low
Priority Normal
Reported Version Version 3.1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

With keyclick set, I can only hear the keyclicks when music is playing. When I pause playback, the keyclicks go away.
This task depends upon

Closed by  Michael Sevakis (MikeS)
Thursday, 30 June 2011, 07:23 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in r30097-r30101
Comment by Alex Meyer (binaryhermit) - Monday, 16 February 2009, 19:06 GMT
This should work.
It should have been fixed by r19413/r19415 on December 13 which made it into the 3.1 branch.
You sure you're running 3.1?
Comment by Alex Meyer (binaryhermit) - Monday, 16 February 2009, 19:10 GMT
Nevermind, I can confirm on the mini2g using a custom build of r20007 with USB enabled and the "enable DMA for PCM" patch
Comment by Alex Meyer (binaryhermit) - Monday, 16 February 2009, 19:15 GMT
Also can confirm on official r20017 on the same mini2g
Comment by Andrew Tonner (rakslice) - Monday, 16 February 2009, 19:32 GMT
md5sum rockbox-ipodvideo64mb-3.1.zip:
19906edd7988299d76796b9c48435bd9 *rockbox-ipodvideo64mb-3.1.zip

Claims to be r19569-081223 in on the startup screen and in the config file.
Comment by Thomas Martitz (kugel.) - Sunday, 08 March 2009, 19:37 GMT
This is a limitation due to the way rockbox currently works. There's only 1 pcm buffer (uncompressed sound), which is untouched while music is paused. Therefore you can neither here keyclicks or voice.
Comment by Luke (gaming4jc) - Saturday, 01 January 2011, 00:30 GMT
Confirming and still present on Ipod Nano 2nd gen running 3.7.1.

Loading...