Rockbox

Tasklist

FS#9922 - Status bar does not show itself in menus for plugins

Attached to Project: Rockbox
Opened by Joshua Simmons (mud) - Tuesday, 17 February 2009, 18:43 GMT
Last edited by Jonathan Gordon (jdgordon) - Friday, 27 February 2009, 08:25 GMT
Task Type Bugs
Category Plugins
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

r20030:
When a menu is opened in a plugin, the status bar often does not show itself. In plugins where there is colourful content at the top of the screen, this looks quite ugly because the previous content shows through and clashes with the rest of the menu.

Incomplete list of plugins which exhibit this problem:
- Goban
- Mazezam
- Sokoban (doesn't look bad, but the status bar doesn't draw)
- Wormlet

It is the most noticeable in Wormlet and Goban

Steps to reproduce:
1) Start the device and load the Wormlet plugin
2) Select "Play Wormlet!" from the menu.
3) Open the menu again (power button on e200).
4) Notice that the blue background shows through where the status bar should be.

Note: you may have to repeat steps 2-3 several times for the bug to appear, but it is at least 1/2 of the time on my e200. Sometimes the status bar will draw itself after a delay (seems to be different each time), and sometimes it will never draw no matter how long I wait.

The bug is evident in the e200 simulator as well, and in other devices' simulators, but it appears to happen less often (you may have to repeat steps 2-3 above a few more times than on the device).

Tested with default settings with the r20030 build downloaded from the website (not built myself).
This task depends upon

Closed by  Jonathan Gordon (jdgordon)
Friday, 27 February 2009, 08:25 GMT
Reason for closing:  Fixed
Additional comments about closing:  fixed in r20126.
Comment by Joshua Simmons (mud) - Wednesday, 18 February 2009, 20:07 GMT
Here's a patch that fixes the bug.

Tested on:
e200 (both with statusbar on and off)
e200 sim
various other sims
all targets seem to build fine

Patched against r20042.
Comment by Thomas Martitz (kugel.) - Friday, 27 February 2009, 02:56 GMT
This fix equals to reverting how the statusbar worked in previous times.
Comment by Joshua Simmons (mud) - Friday, 27 February 2009, 03:01 GMT
Huh? I don't know what the old way was, but look at it now; it's clearly broken and looks horrible in plugins. This just force draws it once when a do_menu is first opened.

Loading...