Rockbox

Tasklist

FS#9944 - RBUtils gets into a configuration loop when it fails to write config files.

Attached to Project: Rockbox
Opened by Hawson (hawson) - Monday, 23 February 2009, 01:33 GMT
Last edited by Dominik Riebeling (bluebrother) - Wednesday, 25 February 2009, 20:56 GMT
Task Type Bugs
Category Rbutil
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Version 3.1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

RBUtils should return a error message when failing to write a configuration file due to file permissions issues.

Currently, when rbutils lacks write permissions to the mount point, an error message that reads "The configuration is invalid... Starting the configuration dialog." Upon closing the configuration dialog (with correct information), the message about "The configuration is invalid..." appears again immediately. There is no delay, nor chance to chose other menu options. Obviously, rbutils has failed to write the configuration file correctly, and is trying to do so again.

Instead, rbutil should return an error message that indicates writing the configuration file has failed (and perhaps a hint to check the permissions on the mount point).
This task depends upon

Closed by  Dominik Riebeling (bluebrother)
Wednesday, 25 February 2009, 20:56 GMT
Reason for closing:  Fixed
Additional comments about closing:  r20100 adds configuration checks to the configuration dialog, pointing out errors earlier and more detailed.
Comment by Dominik Riebeling (bluebrother) - Monday, 23 February 2009, 17:47 GMT
Upon configuration Rockbox Utility does NOT write any configuration file to the player (its configuration is placed on the PC in the usual configuration folder -- ~/.config/rockbox.org on linux, \Documents and Settings\user\Application Data\rockbox.org). It however checks if the mountpoint is writeable. There's no point in a non-writeable mount point as that would make everything else fail. Thus the error is correct: the configuration is invalid (though the error message is somewhat too general). Under which cases should the mountpoint being read only be assumed? Please explain. This is clearly an error in the PC - player setup.

You can leave the described loop by exiting the configuration dialog using the Abort button instead of Ok.

Please don't claim things done by rbutil unless you know it or have checked it. "Obviously, rbutils has failed to write the configuration file correctly" is completely wrong. It discovered that the mountpoint you chose won't work for installation which is intentional.
Comment by Dominik Riebeling (bluebrother) - Monday, 23 February 2009, 22:12 GMT
Ok, after some research figured that sudo also does nasty things here. It's possible to work around this though I'm not sure if this would be a good solution. Unfortunately your report is too terse to indicate if this is the issue as that would only happen on linux. You unfortunately neither stated the version of rbutil used nor the OS you're running it on. Also, you speak about missing write permissions for the mount point first, then writing the configuration later (which could have happened if the sudo issue hit; still, a non-writeable mountpoint doesn't make writing the configuration fail). Can you please clarify this? I'm seeing two issues here and have neither an idea which one you were experiencing nor why.
Comment by Hawson (hawson) - Tuesday, 24 February 2009, 01:42 GMT
Apologies. I asked in the IRC channel first, and posted the relevant info there (versions, etc), but neglected to include them here. rbutils version 1.0.9, 32bit as downloaded (e.g. not locally compiled). Linux kernel 2.6.28 with the tuxonice patches.

I agree that a read-only mount point is a user problem; not something to be fixed by rbutils. The issue is with the error message being somewhat unhelpful. The impression I got from the error message was that there was an issue saving the configuration due to mount point permissions. This was wrong, of course, but still confusing.

As I see it, there are two minor rbutil issues:

1) The error message being slightly misleading.
2) The configuration "loop", with no obvious fix, or help for a solution, from *within* the program.

I didn't check running rbutils under sudo, as is not reason to do so. Just set the 'user' option in /etc/fstab for the mount point in question, and it should be good to go.

/dev/sda1 /mnt/sandisk vfat user,sync,noauto 0 0

Loading...