Rockbox

Tasklist

FS#9955 - Bootloaders for 3.4 - please test

Attached to Project: Rockbox
Opened by Jonas Häggqvist (rasher) - Thursday, 26 February 2009, 00:32 GMT
Last edited by Frank Gevaerts (fg) - Friday, 07 August 2009, 10:38 GMT
Task Type Patches
Category Bootloader
Status Closed
Assigned To No-one
Operating System PortalPlayer-based
Severity Low
Priority Normal
Reported Version Version 3.1
Due in Version Next release
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

These are bootloaders for the PP targets which will be released with USB enabled for 3.2. As the main feature, they do not boot the OF when booting with USB inserted.

Please test and report back. The zip contain all bootloaders placed in a directory structure that should be self-explanatory.

Tested BROKEN:

Tested OK:
- Ipod 4G
- Ipod Video
- Iriver H10-5GB
- M:Robe 100
- Sansa C200
- Sansa E200
- Sansa E200R
- Iriver H10 (20GB)

Needs testing:

It turns out that these bootloaders haven't changed behavior for Ipods, so no need to test those, as we won't be releasing updated bootloaders for Ipods.
This task depends upon

Closed by  Frank Gevaerts (fg)
Friday, 07 August 2009, 10:38 GMT
Reason for closing:  Out of Date
Additional comments about closing:  There are newer bootloaders already on the download server, just waiting to be moved to the right place. These are also available from the "Official Test Builds" forum
Comment by Tom Ross (midgey34) - Thursday, 26 February 2009, 00:42 GMT
iPod 4G:
Loading Rockbox: works
Loading OF: works
On USB insert Rockbox is loaded
Comment by Jonas Häggqvist (rasher) - Thursday, 26 February 2009, 01:02 GMT
Sansa e200:
Loading Rockbox w/sdhc: works
Loading Rockbox wo/sdhc: works
Loading OF w/sdhc: works
Loading OF wo/sdhc: works
USB insert w/sdhc: works (Rockbox boots and connects)
USB insert wo/sdhc: works (Rockbox boots and connects)
Comment by James Davis (advcomp2019) - Thursday, 26 February 2009, 09:56 GMT
On my e280R with or without the 4GB microSDHC card, it will not boot. Even plugging it in, it will not boot. It just gets stuck at the SanDisk boot sceen.
Comment by James Davis (advcomp2019) - Thursday, 26 February 2009, 10:06 GMT
Found out that the zip file does not have the e200R bootloader.
Comment by Jonas Häggqvist (rasher) - Thursday, 26 February 2009, 10:45 GMT
Oops, here's a an E200R bootloader.
Comment by Rui Araújo (Akur) - Thursday, 26 February 2009, 10:55 GMT
H10 5Gb:

Loading Rockbox:works
Loading OF: doesn't work (Hangs after the "Using the default key" string )
USB inserts loads the OF
If the H10 is loaded with Rockbox and the USB is inserted, it works perfectly
(although my linux box recognizes a DAP when plugging from the OF and when using Rockbox it shows my H10 as a mass storage device, but that's okay)
Comment by Seheon Ryu (cpu98) - Thursday, 26 February 2009, 11:03 GMT
iPod 5.5G 80GB
Loading Rockbox: works
Loading OF: works
USB insertion: works (Rockbox boots and disk gets mounted)
Comment by James Davis (advcomp2019) - Thursday, 26 February 2009, 11:37 GMT
The e200R bootloader works, but for one bug. If you have the Sansa off and plug it in, it boots into Rockbox, but it will not let the Sansa mount like when it is on then plugging it in.
Comment by Torne Wuff (torne) - Thursday, 26 February 2009, 12:24 GMT
The iPod bootloader didn't boot the OF when USB was inserted anyway.. are there actually any changes in the ipod bootloaders here?
Comment by Michael DiFebbo (medifebbo) - Thursday, 26 February 2009, 13:15 GMT
The iPod bootloader previously booted into Apple's emergency disk mode. It should now use Rockbox's USB mode.
Comment by Boris Gjenero (dreamlayers) - Thursday, 26 February 2009, 15:36 GMT
Also works on iPod 5G 30GB
Loading Rockbox: works
Loading OF: works
USB insertion: works (Rockbox boots, disk gets mounted by Vista)

BTW I've never seen previous versions of the bootloader boot into emergency disk mode.
Comment by James Davis (advcomp2019) - Thursday, 26 February 2009, 16:05 GMT
My bug is a different bug that is not a part of this. It works. You need to use the Main Menu as the Start Screen. The Resume Playback screen will cause the bug that I found.
Comment by Torne Wuff (torne) - Thursday, 26 February 2009, 19:52 GMT
Michael: Not according to ipod.c, which doesn't check USB at all :) The bootloader boots to rockbox, then rockbox reboots to emergency disk mode early in its own startup.
Comment by Michael DiFebbo (medifebbo) - Thursday, 26 February 2009, 20:03 GMT
I stand corrected.
Comment by Barry Wardell (barrywardell) - Friday, 27 February 2009, 10:29 GMT
Regarding Akur's problem of the OF not loading properly, I don't know exactly what the cause is, but I've had to fix similar problems in the past. See r17357, r16837 and r16817 for examples. You'll have to find which commit caused the problem. I think the last definitely known working one was 17357, so bissecting versions since that one should find it fairly quickly. I'd suspect some initialisation is done that shouldn't be when loading the OF (like was fixed in r16837 and r16817).

Unfortunately, I dropped my H10 and broke the hard drive, so can't do the testing myself.
Comment by Henri Valta (cg) - Friday, 27 February 2009, 10:47 GMT
Everything seems to work fine on my e200.
RB USB mode is entered upon cable connection from power-off state with and without SDHC
USB connection mode can still be skipped by pressing the select button during boot.
Keylock prevents boot-up
Comment by Robert Menes (RMenes379) - Friday, 27 February 2009, 13:12 GMT
I'll be testing the c200 bootloader today, and will report back with results.
Comment by Gideon Mayhak (gnafuthegreat) - Saturday, 28 February 2009, 01:34 GMT
I installed the c200 bootloader on my c240 and it is behaving as expected (boots into Rockbox when USB is connected with player off)!

I installed using the sansapatcher for 32-bit Linux linked to in the manual with the following command:

./sansapatcher -a firmware.mi4

I'm assuming that's the correct procedure. Anyway, it seems to be working great! Thanks a lot for your work on this.
Comment by Mark Fawcus (yapper) - Saturday, 28 February 2009, 03:00 GMT
I've installed the bootloader on a c240 and a c250 - both are booting nicely straight into Rockbox.
Comment by Mark Fawcus (yapper) - Saturday, 28 February 2009, 04:46 GMT
After testing a bit more with the c250 I've had a number of problems with r20135 and a SDHC card:
Power off, connect USB - boots rockbox and shows USB plug, but status bar shows playback in progress and it doesn't connect to PC. Disconnecting sometimes gives a data abort (at 00008F20 (0)) and sometimes freezes on the main menu with Resume Playback highlighted and the disk activity icon shown.

Without the SDHC card, it seems to behave correctly. CHKDSK says the SDHC filesystem is clean.
Comment by Mark Fawcus (yapper) - Saturday, 28 February 2009, 04:52 GMT
If I had read the previous posts I would have spotted James Davis' comment "You need to use the Main Menu as the Start Screen. The Resume Playback screen will cause the bug that I found." - same applies with the c250.
Comment by Jonas Häggqvist (rasher) - Saturday, 28 February 2009, 09:59 GMT
The bug mentioned by Mark Fawcus and James Davis is FS#9957
Comment by David Kauffmann (BdN3504) - Saturday, 28 February 2009, 11:51 GMT
I have "installed" the bootloader on an e260 using the recovery mode (Power off-Turn ON lock/hold-Hold down record-Insert USB) and copied the mi4 provided here to the recovery partition. when i connect the device while it is powered off, my pc does not recognize it, but i get the rockbox usb signoon the device. when i remove the usb plug i get a data abort at 00009650 (0).
Comment by David Kauffmann (BdN3504) - Saturday, 28 February 2009, 11:55 GMT
Using sansa patcher with the -a command produces the same error.
Comment by Robin Bertram (berti) - Saturday, 28 February 2009, 13:46 GMT
I installed the bootloader using sansapatcher with the -a command, and everything works fine on my e280
Comment by Jonas Häggqvist (rasher) - Saturday, 28 February 2009, 15:30 GMT
"DJ K" - did you use a current Rockbox build? Specifically, later than r20106.
Comment by Robert Menes (RMenes379) - Saturday, 28 February 2009, 16:35 GMT
New bootloader works on my c250. No problems.
Comment by David Kauffmann (BdN3504) - Saturday, 28 February 2009, 20:17 GMT
r20136
Comment by Jonas Häggqvist (rasher) - Saturday, 28 February 2009, 20:19 GMT
And what is your Start Screen setting set to?
Comment by David Kauffmann (BdN3504) - Saturday, 28 February 2009, 20:35 GMT
wps...
Comment by David Kauffmann (BdN3504) - Saturday, 28 February 2009, 20:35 GMT
i mean "resume playback"
Comment by David Kauffmann (BdN3504) - Saturday, 28 February 2009, 20:40 GMT
i thought r20106 fixed that, didn't it?
Comment by Jonas Häggqvist (rasher) - Saturday, 28 February 2009, 20:59 GMT
No, r20106 fixed  FS#9935  - that's a different bug. FS#9957 is still not fixed.
Comment by Jonas Häggqvist (rasher) - Sunday, 01 March 2009, 22:34 GMT
The H10 5GB bootloader stopped working between r14003 (last one that could boot the OF) and r14015. Every sign points to r14004 breaking it. The OF likely expects the CPU frequency to be set to 80MHz by the bootloader.
Comment by Frank Gevaerts (fg) - Sunday, 01 March 2009, 23:31 GMT
mr100 boots rockbox and the OF, although the OF doesn't work properly (most probably due to missing files on my partitcular player)
Comment by Barry Wardell (barrywardell) - Monday, 02 March 2009, 13:01 GMT
The H10 bootloader has worked more recently than r14003, at least for the 20GB case. Could it be that r16837 needs to be applied for lcd-h10_5gb.c too? Can someone test the attached patch to see if it fixes booting the OF for H10 5GB?
Comment by Jonas Häggqvist (rasher) - Monday, 02 March 2009, 16:05 GMT
These two bootloaders are for the H10 5GB. Built as r20172 with Barry's patch above applied.
Comment by Frank Gevaerts (fg) - Monday, 02 March 2009, 17:53 GMT
H10.mi4.ums.r20172M boots both the OF and rockbox on here.
Comment by Rui Araújo (Akur) - Monday, 02 March 2009, 22:28 GMT
H10.mi4.ums.r20172M can boot rocknox and the OF here too.
Comment by Barry Wardell (barrywardell) - Monday, 02 March 2009, 22:53 GMT
I've committed my patch as r20185.
Comment by Brian Sutherland (rmaniac) - Saturday, 07 March 2009, 17:37 GMT
I have been testing the USB stack with a 5G iPod. My first issue with the stack ended up wiping my library. So, once the stack was functioning well I decided to test it by using to to resync about 180GB of oggs. About 150GB in the battery died. I rebooted into the emergency disk mode and continued my syncing no problem. It seems when the USB stack is in use it is not even charging enough to stop it from dying much less gain power on the battery.
Comment by Michael Hahn (disorganizer) - Saturday, 07 March 2009, 21:20 GMT
e260 works.
but wouldnt it make more sense if on hold when being plugged in the bootloader charges the battery to 100% and then turns off?
Comment by David Kauffmann (BdN3504) - Saturday, 07 March 2009, 23:28 GMT
i Just tested r20231 with this bootloader on a h10 20GB and it looks like it's working. i copied and deleted files and folders, plugged usb in while the device was off (start screen is set to main menu). loading rockbox usb mode worked form there. plugging the device in while being in the main menu worked with no problems. if further testing is needed, please let me know what you want to have tested.
Comment by Tom Ross (midgey34) - Sunday, 08 March 2009, 05:34 GMT
Were you able to boot the original firmware?
Comment by Brian Sutherland (rmaniac) - Sunday, 08 March 2009, 07:04 GMT
If you mean me... yes...
Comment by David Kauffmann (BdN3504) - Sunday, 08 March 2009, 16:16 GMT
i get the following message upon pressing power and "<-":

Rockbox boot loader
Version: r20108-090226
iriver H10 20GB
HTC426020G7CE10
Partition 0: 0x0C 19077 MB
Loading original firmware..
Trying /System/OF.mi4
Can't load /System/OF.mi4
File not found

i have not renamed the file contained in the zip files provided here. shall i rename it and then try again?
Comment by Tom Ross (midgey34) - Monday, 09 March 2009, 06:52 GMT
No I was asking DJ K; I should have been more clear. DJ K, how did you install this new bootloader? I'd expect loading the OF to be fine and it could be a problem with your setup. If not, we'll need to look into the problem.
Comment by David Kauffmann (BdN3504) - Monday, 09 March 2009, 08:36 GMT
I attached the device using the power and "<-" button, searched the system folder, copied the BL from this very thread, safely disconnected and rebooted.
Comment by Barry Wardell (barrywardell) - Monday, 09 March 2009, 10:35 GMT
That error probably just means that DJ K doesn't have the OF.mi4 file in his System dirctory. This file should have been renamed from H10_20GC.mi4 when originally doing the installation. If you don't have it any more, you can reinstall it (using the update feature from http://iriverinc.com/support/mtpupdate/ ), then install the Rockbox bootloader again.
Comment by David Kauffmann (BdN3504) - Monday, 09 March 2009, 12:12 GMT
Yes, sorry. I followed your instructions and woefully had to accept that the iriver firmware updater formatted the device :( luckily i had copied all its contents to a gigabeat f 20, so i just had to copy everything back onto the h10. That's why it took me so long to answer and now i can say: Everything works.

I renamed the iriver-downloaded file to OF.mi4
I copied the bootloader from this thread to the System folder

Starting the original firmware works
Starting rockbox works
Usb connection works
Copying works
Deleting works
Returning to the main menu when the device is removed in the OS works
Comment by Michael Hahn (disorganizer) - Monday, 09 March 2009, 22:42 GMT
regarding the new bootloader with sansa and usb:
when booting rockbox by plugging in the usb connector when the sansa is powered off, ejecting the drive leads to a rockbox crash (data abort or hang).
(the error does not happen when booting the device manually and then connecting... so it must have something to do with the bootloader i suppose).
Comment by Steve Semke (quad) - Tuesday, 10 March 2009, 14:59 GMT
Sansa E280 v1:
- player off, then cable plug in >> player boots to rockbox, but no usb-connection established (also no usb-picture on screen)
- player on, then cable plug in >> player switch to usb-connection with usb-picture on screen

works okay, but would be better if the player also starts the usb-connection when the player was off before.
actually you have to reattach the cable to start the connection.
Comment by Jonas Häggqvist (rasher) - Tuesday, 10 March 2009, 17:34 GMT
Steve Semke: What is your "Startup Screen" setting set to?
Comment by Steve Semke (quad) - Wednesday, 11 March 2009, 13:47 GMT
Startup screen is set to "Database"
Comment by Steve Semke (quad) - Wednesday, 11 March 2009, 13:51 GMT
Testet it with several other start-screens:

Main Menu: works
Files: works
Settings: works
Database: doesn't work

Tested on r20281
Comment by Jonas Häggqvist (rasher) - Wednesday, 11 March 2009, 16:46 GMT
That sounds very related to FS#9957. Thanks for testing! This isn't strictly a bootloader issue though, so I don't think we should block for this. Thoughts?
Comment by Jonas Häggqvist (rasher) - Monday, 16 March 2009, 21:47 GMT
Considering it looks like 3.2 is unlikely to release with USB enabled, there's no need for these.
Comment by Steve Semke (quad) - Tuesday, 17 March 2009, 10:05 GMT
Btw. there seems also an other bug in the bootloader:
It's only possible to quickformat microsd-cards, not full format (under windows).
Testet on latest build with Transcend 1GB and Kingston 8GB SDHC.
Comment by robin (robin0800) - Wednesday, 18 March 2009, 11:33 GMT
My Sansa c240 will only boot from off with certain startup screens selected please add "Resume Playback" to the list that don't allow usb to be detected
Comment by robin (robin0800) - Wednesday, 18 March 2009, 13:36 GMT
It would appear the new Bootloaders are dependent on the start screen setting i.e. this one
........................................................................................................................................................
Comment by Steve Semke (quad) - Wednesday, 11 March 2009, 14:51 GMT+1
Tested it with several other start-screens:

Main Menu: works
Files: works
Settings: works
Database: doesn't work
...................................................................
I merely wanted to say the bad behavior is also seen if the start screen is Resume Playback
Comment by Geoff Pursell (geoffp) - Friday, 12 June 2009, 01:24 GMT
Just tested new bootloader + r21257 on my c240v1.

On Ubuntu 9.04 64bit:

- player off, then cable plug in >> player boots to rockbox, usb-picture on screen, but does NOT mount as a mass storage device
- player on, then cable plug in >> the same.

Bizarre: if I push button on the device, the desktop OS will react by furiously turning the system volume down.

lsusb of the device is attached.
Comment by Dominik Riebeling (bluebrother) - Friday, 12 June 2009, 10:59 GMT
The OS reacting to the buttons isn't bizarre at all -- it's the HID feature sending events to the OS, thus it reacting to it.
Comment by Frank Gevaerts (fg) - Friday, 12 June 2009, 18:21 GMT
Also, there's a bug in ubuntu 9.04 that makes it not work properly with several players, see https://bugs.launchpad.net/ubuntu/+source/linux/+bug/355998 . Not much we can do about it.
Comment by robin (robin0800) - Sunday, 14 June 2009, 00:47 GMT
Just for information, installed ubuntu 9.10 alpha 2 yesterday and it would appear the bug mentioned above is know fixed.
Comment by Geoff Pursell (geoffp) - Sunday, 14 June 2009, 14:23 GMT
Ah, very true. Installing stuff from Karmic has worked for me. https://bugs.launchpad.net/ubuntu/+source/linux/+bug/355998/comments/58 Thanks guys. Works great now!
Comment by Torne Wuff (torne) - Monday, 22 June 2009, 09:26 GMT
Can we release new bootloaders for iPod after all? My change in r20921 to allow booting Rockbox from OSOS is waiting to go out to support the advanced install methods detailed in http://www.rockbox.org/twiki/bin/view/Main/IpodPatcher so it would be nice if we did...
Comment by Jonas Häggqvist (rasher) - Monday, 22 June 2009, 10:22 GMT
I think someone should build a new round of bootloaders, as I forgot a lot of things when building these.

1. Bumping the bootloader version number(s)
2. Displaying that version number rather than the revision during boot
3. Probably other things
Comment by MichaelGiacomelli (saratoga) - Friday, 03 July 2009, 22:33 GMT
Could someone with the tools post Sansapatcher builds with the bootloader binaries in this thread? We'll need those eventually too.

Loading...